New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Desktops Discussion of Apple's desktop machines including Mac Pro, iMac, Power Mac, and mini

Power Mac - Need Extream Help please


Post Reply New Thread Subscribe

 
Thread Tools
maxpol

 
Member Since: Dec 18, 2007
Posts: 3
maxpol is on a distinguished road

maxpol is offline
Hello, I have a huge problem with my G4 quicksilver.

Here is the problem:
My friend accidently unplugged my mac from the outlet while it was on. It didnt turn on since. When i pressed the power button, it would turn on and glow back off. I reset the PRAM and nothing happend. I read online, that you have to hold the PRAM reset for 10sec in order for it to work. I did that, now I put in a new battery.
When I press power, the light turns on and illuminates back off. There is no light on the motherboard and the powersupply fan starts to spin up, and turns off immideatly.

I am in panic not knowing what to do.
Any help appreciated....
PLEASE AND THANK YOU
QUOTE Thanks
MacHeadCase
Guest
 
Posts: n/a

Welcome to Mac-Forums, maxpol.

I once went through a power outage and the only thing that got my Mac back was DiskWarrior. If you have it, now's the time to use it.

You could try to unplug the Power Mac from the electrical outlet for about ten to fifteen minutes, plug it back in. Restart, see where that takes you.

If that doesn't do anything try resetting the CUDA chip.

You could also try what Brown Study suggests here.

Other than that, I'm outta ideas. Hopefully your power supply or some other hardware component didn't fry.

Good luck! Let us know how it goes.
QUOTE Thanks
maxpol

 
Member Since: Dec 18, 2007
Posts: 3
maxpol is on a distinguished road

maxpol is offline
thanks for the suggestion, but I cant even use the keyboard. It started happening after I held the couda reset for 10sec.
It still didnt work.
QUOTE Thanks
MacHeadCase
Guest
 
Posts: n/a

Well unless someone else has another suggestion for you to try, looks like it's time you take your Power Mac in for repairs.
QUOTE Thanks
maxpol

 
Member Since: Dec 18, 2007
Posts: 3
maxpol is on a distinguished road

maxpol is offline
Well, I really want it fixed for as cheap as possible. I really loved it and now....
QUOTE Thanks
ronss

 
Member Since: Oct 08, 2007
Location: phoenix,az
Posts: 47
ronss is on a distinguished road

ronss is offline
maxpol

get ya a mdd dual...and then you will wonder how you could stay with the quicksilver for as long as you did...the mdd,s are very quick. i got a mdd dual 867 for $340, put a 9800 pro in it, i am just tickled to death with it...and i did not pay $3000 for it.
QUOTE Thanks
Tanner31593

 
Tanner31593's Avatar
 
Member Since: Jan 28, 2007
Posts: 1,131
Tanner31593 has a spectacular aura about

Tanner31593 is offline
Same thing happened to a friend and his B&W G3,
power supply went bad.
I would just take it in to Apple (if they will look at it?) and get a diagnosis and go on ebay and get whatever.
Personal call though.
I will dance around singing indian tribal chants hoping for your PowerMac to get well,
the quicksilvers are quite nice eh?
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 17,303
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz OS X.9.4 and OS X.10

harryb2448 is offline
Have a look at this link and hopefully as what happened is similar to your story, you might get something from it.

Good luck-

http://forums.macrumors.com/showthread.php?t=294008
QUOTE Thanks

Post Reply New Thread Subscribe


« Half of SDRAM Recognized on G3 (B&W) | startup issues with my mac pro and display »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Need extream help please radio-years Apple Desktops 3 05-31-2006 02:20 AM
Printer on Airport Extream disconnects. Is it common? Halen Internet, Networking, and Wireless 0 11-28-2005 04:43 PM

All times are GMT -4. The time now is 03:58 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?