Results 1 to 2 of 2
  1. #1

    Member Since
    Dec 06, 2007
    g4 Quicksilver power fault
    I have a powermac g4 800mhz which was working fine until i went to switch it on and the powerlight at the front goes on an then straight back off again.

    I have repleced the ram with others but it still does the same.

    It doesnt make the faulty ram sound and im unsure if its a powersupply fault. The light goes on for a second and then swithches off. It doesnt sound like the hard drives starts up either. I tries another blank hard drive in and that doesnt help either.

    any ideas please.



  2. #2

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Nambucca Heads Australia
    iMac i5 2.7GHz, 16GB memory, OS 10.11.1.
    Here are a number of suggestions to get you started on the fault.

    Hopefully reset the PRAM or internal battery will see you up and running.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. G4 quicksilver wont power up.
    By marklar in forum Apple Desktops
    Replies: 9
    Last Post: 05-14-2010, 06:57 PM
  2. Quicksilver Power Mac G4 HD help.
    By master1321 in forum Apple Desktops
    Replies: 5
    Last Post: 12-29-2009, 04:34 PM
  3. G4 Quicksilver won't power up
    By Alexis in forum Apple Desktops
    Replies: 6
    Last Post: 10-28-2008, 08:49 AM
  4. Can't startup Power Mac G5 - fatal signal: Segmentation fault
    By beck76 in forum OS X - Operating System
    Replies: 4
    Last Post: 08-27-2007, 05:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts