New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Desktops Discussion of Apple's desktop machines including Mac Pro, iMac, Power Mac, and mini

iMac - Ram installation problem


Post Reply New Thread Subscribe

 
Thread Tools
zacster

 
Member Since: Jun 07, 2006
Location: NYC
Posts: 287
zacster is on a distinguished road
Mac Specs: Intel iMac 20" Core Duo 256mb VRam 115gb SSD 2gb Ram Finally!!!

zacster is online now
I have an older Intel 20" iMac, mid 2006 model (is that really older?). It came with the standard 512mb since I took everyone's advice and didn't order more from Apple.

I tried to add another 1gb to it last year but couldn't get it to work, so I just gave up on it and I figured it was a bad stick. I tried installing it multiple times, swapped the slots, cleaned the contacts. I would just get a fast flash on restart. It isn't like I do a lot on it anyway, mostly surf and iTunes. My son however is turning into quite the musician and was complaining about it sometimes being a little slow when recording.

Yesterday, my 2 new samsung 1gb sticks arrived and I tried installing them both. Same thing, a fast flash. I pulled the lower stick out and tried that and it worked, so now I'm up to 1gb in the machine and it does seem faster and more responsive, particularly with MS Word/Excel, which aren't native.

My question is what to try next? I'm beginning to think that one slot has a problem, or maybe I'm doing something wrong? Any advice? (my system spec is wrong on my profile, I never got the extra to work.)
QUOTE Thanks
Chilbear

 
Chilbear's Avatar
 
Member Since: Jun 14, 2007
Location: Toronto
Posts: 574
Chilbear is on a distinguished road
Mac Specs: 2xiMac24 w Parallels 6 (1x White, 1x Aluminum), iPhone 3GS with iOS5

Chilbear is offline
Maybe backing up and trying something to sleuth the problem.

You said the 1 x512 stick and 1x1gb worked. Have you tried the 512 stick in the other slot all by itself? If it flashes/fails then yes the slot looks to be the issue. If not leave it there and put the 1gb stick in. If they fail then my best guess is the computer firmware is confused.

Last solution is to return the 2x1gb you bought and get 1x2 and install it in the one good slot.
QUOTE Thanks
zacster

 
Member Since: Jun 07, 2006
Location: NYC
Posts: 287
zacster is on a distinguished road
Mac Specs: Intel iMac 20" Core Duo 256mb VRam 115gb SSD 2gb Ram Finally!!!

zacster is online now
My understanding is that this particular model will only work with 1gb sticks, one in each slot.

Anyway, I tried using other combinations, and the only two that have worked so far is the original 512 in the top slot, and the new 1gb in the top slot. The older 1gb stick did not work, nor does anything work in the bottom slot.

I haven't had a chance to try again, so I'll try all the combinations. This computer gets heavy use even if only for music and surfing. I can't wrest it away from my wife and kids.
QUOTE Thanks
Chilbear

 
Chilbear's Avatar
 
Member Since: Jun 14, 2007
Location: Toronto
Posts: 574
Chilbear is on a distinguished road
Mac Specs: 2xiMac24 w Parallels 6 (1x White, 1x Aluminum), iPhone 3GS with iOS5

Chilbear is offline
Can you see the memory/slots from System Profiler? You should be able to see each slot and what is in it.
QUOTE Thanks
rhcpcjg

 
rhcpcjg's Avatar
 
Member Since: Oct 24, 2007
Posts: 12
rhcpcjg is on a distinguished road

rhcpcjg is offline
I would say its a bad slot, ram rarely goes bad... call apple if you still have warranty or if you purchased apple care.
QUOTE Thanks
Alexis

 
Alexis's Avatar
 
Member Since: Apr 20, 2006
Posts: 2,255
Alexis is a jewel in the roughAlexis is a jewel in the roughAlexis is a jewel in the rough
Mac Specs: Al iMac 20" 2.4Ghz Intel Core 2 Duo

Alexis is offline
Quote:
My understanding is that this particular model will only work with 1gb sticks, one in each slot.
No, that's incorrect. Put the 512 meg stick in the 'faulty' slot. It should recognise it.
QUOTE Thanks
zacster

 
Member Since: Jun 07, 2006
Location: NYC
Posts: 287
zacster is on a distinguished road
Mac Specs: Intel iMac 20" Core Duo 256mb VRam 115gb SSD 2gb Ram Finally!!!

zacster is online now
Yes, of course the 512 still works too. I meant the upper limit was the 1gb.

I haven't had a chance to try anything else yet. I did buy Apple care so if it is a bad slot they can take care of it.

The problem with using system profiler is that the computer has to boot up to use it. With bad memory it doesn't boot.
QUOTE Thanks
zacster

 
Member Since: Jun 07, 2006
Location: NYC
Posts: 287
zacster is on a distinguished road
Mac Specs: Intel iMac 20" Core Duo 256mb VRam 115gb SSD 2gb Ram Finally!!!

zacster is online now
I've had a chance to play around with it and I can't get anything to work in slot 0, the lower slot when it is laying on the face. The upper slot takes anything I put in it.

I guess it is the slot then, and my next stop is the Apple store in Soho.
QUOTE Thanks
gspencer9

 
Member Since: Dec 01, 2007
Posts: 1
gspencer9 is on a distinguished road

gspencer9 is offline
Just today I'm trying to add 2, 1gb sticks to my 2004 iMac. I'm getting the exact problem that you are. (i.e., one stick works, two sticks don't work) I'd be interested to know if your slot ends up being the culprit.
QUOTE Thanks

Post Reply New Thread Subscribe


« Mac Pro GeForce 7300 GT - 24" monitor? | New iMac: when, where to buy? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Final Cut Studio 2 Installation problem wacfoo OS X - Apps and Games 12 01-04-2009 06:37 AM
if i have a mac problem, do I tell the geniuses that i installed my own ram? milk is white Switcher Hangout 3 09-14-2007 04:42 AM
RAM upgrade problem jpierson Apple Notebooks 1 06-20-2006 09:54 PM
Is it worth to switch from iMac G4 to iMac G5?? Mainyehc Apple Desktops 12 03-13-2006 07:21 PM
G5 Video problem WilliS Apple Desktops 3 05-05-2004 10:16 AM

All times are GMT -4. The time now is 09:02 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?