Results 1 to 5 of 5
  1. #1

    Member Since
    Oct 21, 2007
    Powermac G5 Dual 1.8 won't boot
    My Powermac G5 Dual 1.8 won't boot up. It turns on, there is the chime, and I get the Apple logo but no spinning wheel. After awhile the fan speed increases. Can't even boot to the install disk. I changed out the battery, reset the pram...still no boot.

    your suggestions and comments would be most appreciated.


  2. #2

    Member Since
    Jan 27, 2007
    17 inch 2 GHz C2D imac (5,1) with 3GB DDR2 RAM, X1600 (128MB memory) GPU - OSX 10.6.3
    Have you added any new ram into the machine. It might be a hardware issue. I think it probably is a hardware issue. And when you try to boot your machine count the seconds before the fans speed up and the thing freezes. Is this time the same every time or different every time.

    And I've heard the chime is there to say the machine is ok internally then it'll try to load up the system. SO maybe there is a conflict between the hardware and the system.

    I dunno I'm just pulling at straws here. Maybe someone else here will be able to help you more.

  3. #3

    Member Since
    Oct 21, 2007
    thanx joel
    The ram is ok. It is not a freeze issue. The fan comes on after about 3 minutes everytime. I just get the apple logo.

  4. #4
    Welcome to Mac-Forums, jerriji.

    Could you give us a few more details so we can help? Which OS version are you running (example: not OS X Tiger but 10.4.7)?

    In the meantime, see if this applies to you.

  5. #5

    Member Since
    Oct 21, 2007
    Reply:Powermac won't boot...
    When I first started it up after being in storage for a year, I was running 10.3.9. I was living with friends at the time who live off the grid. They have solar panels/inverter and a generator. They say they have a pure sine wave inverter but are not sure. When the new harddrive was installed I also had Tiger put in. I live off the grid as well have solar panels/pure sine wave inverter and a EU3000 Honda generator which has an inverter built in. After the tech installed the new harddrive and 10.4. It worked in his shop but did exactly the same thing when I fired it up back at my place. When I took back into the shop, He could only get to boot to the the install disk(10.4) and that was intermitant. Took back home....still no boot.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PowerMac G5 won't boot
    By elementalmist in forum Apple Desktops
    Replies: 5
    Last Post: 08-19-2014, 05:53 PM
  2. PowerMac G5 won't boot from disk
    By kribensis12 in forum Apple Desktops
    Replies: 8
    Last Post: 02-13-2014, 09:16 PM
  3. PowerMac G4 Dual Optical - will not boot & no display
    By mike23 in forum Apple Desktops
    Replies: 8
    Last Post: 10-05-2009, 05:34 PM
  4. G3 powermac won't boot
    By switchedtomac1 in forum Apple Desktops
    Replies: 5
    Last Post: 03-07-2006, 05:48 PM
  5. Powermac G5 Dual 1.8 Won't power up. Help!
    By suspectinc in forum Apple Desktops
    Replies: 0
    Last Post: 02-15-2006, 03:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts