Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Apple Desktops (http://www.mac-forums.com/forums/apple-desktops/)
-   -   iMac update broke my iSight! (http://www.mac-forums.com/forums/apple-desktops/80812-imac-update-broke-my-isight.html)

disasterboy 10-17-2007 03:16 PM

iMac update broke my iSight!
 
hey all, i just updated my iMac using the updater that pops up occasionally, i restarted like it told me to and then when i went to use my built in iSight...it won't work, it says that there is no camera attached? anyone know of a solution to this as i use my iSight everyday!

Any help or advice is greatly appreciated!

pnstps 10-17-2007 03:54 PM

try restarting agin

disasterboy 10-17-2007 04:00 PM

i've done that several times and its not doing anything. i just read on the apple forums that a few other people have experienced the same thing, i really hope apple sort this out soon!

disasterboy 10-17-2007 05:37 PM

anyone else have an idea's? aome people are saying that its a bug in the most recent EFI update ..i hope i got that right! is there anyway to roll this back?

MacHeadCase 10-17-2007 06:03 PM

Do you have the iSight's green light on all the time?

Btw, you might want to try these steps as suggested by Apple, How to Troubleshoot iSight. More specifically this step, Intel-based iMac, Intel-based Mac mini: How to reset the System Management Controller. You do have the Intel-based iMac?

disasterboy 10-17-2007 06:52 PM

no the light doesnt come on at all, for instance, if i open photo booth, it says no camera is connected, or that it is in use. this is all after in upgraded the EFI firmware!

MacHeadCase 10-17-2007 06:53 PM

Ok. Did you try what I suggested above?

disasterboy 10-17-2007 07:40 PM

ok so i followed one of the links you provided to the part where it describes how to reset the SMU. this worked perfectly, my cam is working again! however...now my fans in the iMac are going absolutely crazy! i have to shout to talk over them and they sound like theyre going way too fast! i'm really worried that its gonna blow up or something! someone help! and fast! please!

disasterboy 10-17-2007 07:56 PM

ok, it's all sorted now! thanks god! i was worried there that my mac was gonna blow! lol anyways what i did was firstly was to reset the SMU. this is what fixed my iSight, but made the fans go insane! obviously i couldn't leave them going that fast, so i thought what the hey and tried the method to reset the SMC, and thankfully this cured the fan problem! i'm all back to normal now, so thanks so much MacHeadCase! you are a life saver!

MacHeadCase 10-17-2007 08:16 PM

Glad it's working again! Enjoy your iMac! :)


All times are GMT -4. The time now is 05:04 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.