Results 1 to 14 of 14

Thread: Help computer starts but no screen or mouse working?

  1. #1


    Member Since
    Sep 09, 2007
    Posts
    11
    Help computer starts but no screen or mouse working?
    This is an emergency!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    when i turn on my G5 it revs up high and the power button blinks TWICE every 3 seconds.
    no output to the screen or mouse either.
    I need help Fast
    Thanks so much in advance

  2. #2

  3. #3

    bryphotoguy's Avatar
    Member Since
    Feb 02, 2007
    Location
    Chicago, IL
    Posts
    3,978
    Hold down Apple, Option, P, R right after you you power it on. I doubt it will work but give it a try.
    Or disconnect everything, every cable from your computer and give it a minute to cut all it's power so it resets itself.
    I don't know what else to try.
    -Peace

    January 2008 Member of the Month

  4. #4


    Member Since
    Mar 30, 2004
    Location
    USA
    Posts
    4,744
    Quote Originally Posted by litebulb1 View Post
    you can look this article over but if it doesn't help call apple care.

    http://docs.info.apple.com/article.html?artnum=303234
    Wrong article. The one you want is
    http://docs.info.apple.com/article.html?artnum=300537

  5. #5


    Member Since
    Sep 09, 2007
    Posts
    11
    I tried the Command, option, p,r but i did nothing so , i unpluged everything and will let it sit for a half hour or so

  6. #6


    Member Since
    Sep 09, 2007
    Posts
    11
    NOpe it still just turns on and the power light blinks and nothing is sent to my mouse or screen. what the @#$%

    ANY other ideas?


    Of course I have a Huge homework assingmet to do , and this happens

    Why me, why now

  7. #7
    MacHeadCase
    Guest
    Could you give more details about your Mac other than it's a single G5? Is it a PowerMac G5? An iMac G5? Which model? It runs on which version of OS X? 10.3.9? 10.4.6?

    There are recall programs for certain PowerMac G5s and certain iMac G5 models.

  8. #8

    Bear Hunter's Avatar
    Member Since
    Sep 03, 2007
    Posts
    118
    Quote Originally Posted by boknows View Post
    NOpe it still just turns on and the power light blinks and nothing is sent to my mouse or screen. what the @#$%

    ANY other ideas?


    Of course I have a Huge homework assingmet to do , and this happens

    Why me, why now

    I know exactly how you feel. I was writing a paper that was due the next day and my Powerbook had a volume failure that could not be fixed or mounted....so I said "ok", I'll just re-type everything from memory on the eMac....so now it's 2200hrs, I finish the first page and the screen on the eMac starts to flicker, then completely fizzes out complete with a "burning smell". Yep that's right BOTH of my computers crap out in the same day. The Apple Care plan didn't do jack for me because I was 5 months outside the 3yr window.

    Anyway, hope you got it figured out...your symptoms sound similar to what occured with my powerbook...it would only boot up to a blue screen.

  9. #9


    Member Since
    Sep 09, 2007
    Posts
    11
    still nothing working, would a shaky video card cause problems, the screws won't tighten for some reason so maybe its not grounding properly?.

    Bear hunter That blue screen thing did happen once ,
    what was the fix for that problem?

    my mac Is a G5 tower not an imac but i can't remember what osX it runs on

  10. #10

    bryphotoguy's Avatar
    Member Since
    Feb 02, 2007
    Location
    Chicago, IL
    Posts
    3,978
    even if the screw did not tighten properly the card should still be quite secure in the slot. If you can move it around it isnt connected fully and possibly why you are having this problem ( which might have been helpful yesterday if you told us the whole story.)
    open th case and make sure it's connected. Make sure it stays connected when you reconnect the monitor cable.
    -Peace

    January 2008 Member of the Month

  11. #11


    Member Since
    Sep 09, 2007
    Posts
    11
    ok i took the card out and checked it , it looks fine .
    its back in and secure with a new screw but still no action to my screen or mouse, i tried different monitors and still nothing
    I'm going crazy what the heck is wrong!

  12. #12
    MacHeadCase
    Guest
    Did you try resetting the Cuda chip?

    Also check to see if your serial number wouldn't be this list, Power Mac G5 Repair Extension Program for Power Supply Issues.

    And you did unplug it from the electrical outlet and let it wait for 5 minutes or so? This helps the capacitors drain.

  13. #13

    Bear Hunter's Avatar
    Member Since
    Sep 03, 2007
    Posts
    118
    Quote Originally Posted by boknows View Post
    still nothing working, would a shaky video card cause problems, the screws won't tighten for some reason so maybe its not grounding properly?.

    Bear hunter That blue screen thing did happen once ,
    what was the fix for that problem?

    my mac Is a G5 tower not an imac but i can't remember what osX it runs on
    In my case the fix would have been to purchase a new hard drive....the HD was not repairable and it prevented it from booting up. I ended up buying two new computers.

  14. #14


    Member Since
    Sep 09, 2007
    Posts
    11
    i changed out the RAM and it starts up again , i'll have to upgrade to more RAM. thanks for your help everyone!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mac starts up with black screen
    By GypsyTears in forum Apple Desktops
    Replies: 15
    Last Post: 06-16-2014, 07:50 PM
  2. Screen saver starts but is dissabled
    By Medova in forum macOS - Operating System
    Replies: 3
    Last Post: 01-22-2012, 09:19 AM
  3. 10.5.6 computer starts then shuts down
    By iceracer in forum macOS - Operating System
    Replies: 7
    Last Post: 07-05-2011, 05:05 PM
  4. split screen when os starts up! help?!
    By sentinelcases in forum macOS - Operating System
    Replies: 5
    Last Post: 11-03-2010, 03:59 AM
  5. Windows starts fine then the computer shuts down?
    By me262 in forum Running Windows (or anything else) on your Mac
    Replies: 0
    Last Post: 11-22-2007, 12:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •