Results 1 to 4 of 4
  1. #1

    Member Since
    Mar 10, 2007
    G4 - Drive problems... ?
    I have been having an ongoing issue with my PowerMac G4 tower. I just rebuilt it about 2 months ago and finally got everything back to where it was and then I was just doing some regular maintenance by running a fsck and I got the same error that I got before everything died 2 months ago. The error was about invalid number of allocation blocks (I can't recall the exact error). Nevertheless, the only way I am able to repair it so I can perform a fsck is to run DiskWarrior. DiskWarrior then reports there is Volume Header information that it has to fix before it can do anything else, so I let it fix it. The drive, which is 320GB, will then only report that it's 128GB. So what I am starting to believe is that having this drive plugged in on the internal IDE cable only permits drives up to 128GB or something to that effect because other means of looking at the drive is fine (i.e. usb, firewire). I guess I should also note that when I checked the system.log file it shows there are a bunch of disk I/O errors on the drive so I'm not sure if this might have something to do with handling the capacity of the drive properly and writing to the disk. And I truly don't believe it's an actual HD problem because this has happened with two brand new drives, one being 300GB and one being 320GB. One last thing I wanted to note is that before I did any of this stuff I just rebooted the machine and I lost all my profile settings (view options, etc.) and other things like iTunes library was all effed up so I don't know if that adds any value but throwing it out there.

    My big concern is that I don't want to rebuild this machine again if the problem is with the size of the drive and have it do the same thing again two months from now.

    If anyone has any suggestions or thoughts about this they would be greatly appreciated.


  2. #2

    rman's Avatar
    Member Since
    Dec 24, 2002
    Los Angeles, California
    2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi
    There is a system in which you can not install anything larger than 128GB. I believe to get around the problem you had to partition the disk, with partitions less than 128.
    Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!

  3. #3

    baggss's Avatar
    Member Since
    Oct 10, 2004
    27" 3.4 Ghz i7 iMac-13" C2D Macbook-OSX 10.10.2 -64Gb iPad 2-64 Gb iPhone 6+-ATV 2-14Tb of Storage
    Your G4 suffers from a limitation in disc size. This is a firmware issue that has never been updated by Apple. You can:

    A) Partition the disc.
    B) Buy a PCI IDE card that supports drives above 128Gb.

    I chose option B on my old G4 and it worked like a charm for drives up to 400Gb.

  4. #4

    Member Since
    Oct 27, 2006
    I am surprised you go that far! Your G4, as baggss and rman stated, can not see more than 128 gigs. The volume header problem is not "real" so you are trying to fix a problem that is inherently built in.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Macbook drive problems
    By ilikestella in forum Apple Notebooks
    Replies: 2
    Last Post: 09-26-2011, 11:40 AM
  2. CD drive problems :(
    By PACEMKR in forum OS X - Operating System
    Replies: 4
    Last Post: 04-12-2011, 12:36 PM
  3. CD Drive problems :(
    By Kylemac in forum Apple Notebooks
    Replies: 5
    Last Post: 12-14-2007, 11:03 AM
  4. Problems with CD Drive.
    By VictoryRed in forum Apple Notebooks
    Replies: 2
    Last Post: 01-10-2007, 01:04 PM
  5. Help! Problems with CD drive
    By Layoyox in forum Apple Notebooks
    Replies: 4
    Last Post: 05-18-2006, 12:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts