I'm having real issues with Safari on my twin G5, OSX panther...

I much prefer the functionality of IE, and would like to use that as my default browser.

I've set it in all my system and application prefs, but whenever I check my hotmail through MSN messanger, Safari pops up! I've even set IE as my default browser *in* safari, and this doesn't help!

Can anyone tell me how to get round this? I'm getting annoyed with the inability to 'option-click save link as' in safari, and being constantly reminded about resending forms in hotmail.... Aargh!

If I delete Safari altogether- will that stop it?