Results 1 to 9 of 9
  1. #1
    PowerMac G4 AGP - Dead?

    Member Since
    Apr 13, 2007
    Posts
    6
    Unhappy PowerMac G4 AGP - Dead?
    Hi All,

    Okies, I picked up a second hand Apple G4 AGP the other day off eBay - was working fine when I got it, but since then i've upgraded the hard drive (I think the original was on its way out as it kept spinning up and down during use), installed a USB 2 card and installed 2x 256MB Crucial DIMM's to bring the system to 1GB - I was able to reinstall OS X 10.4.9 no problems. I also upgraded the DVDRW drive (to a LiteOn model). Has been working fine for about a week, but I tried installing some software and that's when the system went to pot. I tried installing Office X, Creative Suite and Toast Titanium. Office went on fine, but Word crashes at startup with an error, but the other Office apps work fine. The same error happens when I try and load Toast, and the installer for Creative Suite crashed too, with an unexpected error.

    I tried restarting, then it said the clock was showing 2001, and it crashed (OS crash), upon restarting there was no video output for ages, although I got the chime at power-on or during a hard-reset. I left it off for a while and also tried holding the power button, which seemed to bring it back to life, but not for long - it's dead Jim!

    The system powers on fine, green light at the front, including the chime, but no output from the video (tried different monitors). I also tried removing all the components I recently installed to the bare motherboard (minus original RAM supplied with the system when working and the graphics card).

    Any ideas what I can try or what it might be - or is it "return to sender" time?

    Thanx, Richard

  2. #2
    PowerMac G4 AGP - Dead?
    baggss's Avatar
    Member Since
    Oct 10, 2004
    Location
    Margaritaville
    Posts
    10,310
    Specs:
    27" 3.4 Ghz i7 iMac-13" C2D Macbook-OSX 10.10.2 -64Gb iPad 2-64 Gb iPhone 6+-ATV 2-14Tb of Storage
    Insert the system CD/DVD and hold down the C key from booting. If it starts up, then it's a software/system problem. If you get the same results, it's a hardware problem.


  3. #3
    PowerMac G4 AGP - Dead?

    Member Since
    Apr 13, 2007
    Posts
    6
    Yeah, i've tried all of this, one time I did manage to get it to startup while holding the C key, but it just froze on the spinning logo (before it would get to either the OS X loader or the boot loader from the CD). Since then I haven't had any luck, no display, although everything is running (chime at power-on etc) it seems rather dead.

    Any ideas what I can now do to troubleshoot the system?

  4. #4
    PowerMac G4 AGP - Dead?
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,480
    Specs:
    iMac late 2007 10.11.b4, iMac 2008 10.10.5, Macbook2007 10.7.5, Mac Mini 10.7.5, iPhone 3GS Note 8!!
    Since at one point it said the date was at 2001, I am wondering of the PRAM battery is dead. Some Macs will not light the display if that battery is dead. Also try holding down the following keys at the same time right after the chime, APPLE-OPTION-P-R. Keep them down and wait for 2 sets of chimes then let go. See if that brings it back to life. If not try the battery. you will see it on the Motherboard with a black cover on it. 3.6 Volts. You can get them either on Ebay or at a lot of Radio Shacks.

  5. #5
    PowerMac G4 AGP - Dead?

    Member Since
    Apr 13, 2007
    Posts
    6
    Thank you for the advice, I will get out the multimetre and give it a quick check. I am curious, what is the recessed button on the front of the G4 unit, next to the reser button for - when pressed it seems to do nothing...

  6. #6
    PowerMac G4 AGP - Dead?
    Audio.Trench's Avatar
    Member Since
    Oct 03, 2005
    Location
    Ontario, Canada
    Posts
    2,722
    Specs:
    Custom PC
    That's so odd.. My G4 Sawtooth did the EXACT same thing.. Except it wouldn't reset the PRAM, and the PRAM battery is still good.. I even replaced the video card, ram, harddrive. But still no avail.. Now my idea for a media server went down the tube..

  7. #7
    PowerMac G4 AGP - Dead?

    Member Since
    Apr 13, 2007
    Posts
    6
    Ok, I just tried that and it seems to have brought it back to life - for now - but applications still crash when I attempt to load them, such as MS Word, Toast Titanium and I can't install Creative Suite - just crashes during the installer on Disc 1

  8. #8
    MacHeadCase
    Guest
    I dunno what others think of this but...

    I'm not sure which DVD RW LiteOn model you installed but I checked the specs of all these out and they only list Windoze for compatibility...

  9. #9
    PowerMac G4 AGP - Dead?

    Member Since
    Aug 29, 2006
    Location
    Tampa, FL
    Posts
    217
    Specs:
    Powerbook G4 12" 1.5GHz
    I installed a newer IDE Lite-On DVD-RW in one of my G4 MDDs and G4 DA and they both worked fine. I couldn't tell you the model number off the top of my head.

    I would try reinstalling OSX. If you still get problems, the next time it hangs on startup at a blank screen, try to remove the hard drive then power up. It could be your motherboard/logic board biting the dust; I would try replacing the battery as well.
    12" Powerbook G4 1.5GHz/512MB/Superdrive/100GB Seagate Momentus 7200.1
    PowerMac G3 B&W 350MHz/1GB/DVD-RW/Adaptec 39160 2X Seagate 36GB 15k RAID0
    Dell E521 AMD X2 4600+/2GB/7600GT/320GB Seagate Barracuda 7200.10

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. upgrading AGP PowerMac G4
    By supenguin in forum Apple Desktops
    Replies: 5
    Last Post: 02-02-2009, 07:47 AM
  2. Powermac G4, (AGP Graphics)
    By Mr. Quackens in forum Apple Desktops
    Replies: 6
    Last Post: 04-29-2008, 04:40 PM
  3. powermac g4 (agp) upgrade questions
    By MAC1av3lli in forum Apple Desktops
    Replies: 4
    Last Post: 10-19-2005, 11:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •