Results 1 to 5 of 5
  1. #1


    Member Since
    Feb 22, 2007
    Location
    Minneapolis
    Posts
    3
    Specs:
    PowerBook, MiniMac
    Question Updated my firmware, now having fireware issues
    I have a
    1.66 GHz Mini
    2 GB Ram
    Blah Blah Blah

    Basically heres the problem I'm having. I updated my firmware, cause Apple Update said I needed to, I thought. Now my firewire and usb ports don't work. Well they work but, I have a external HD that is firewire. Whenever I try to copy something off of it things are corrupt. Anyone have any thoughts. I think alls I need to do is some how reset the firmware to the old version. Is this possible? Any info would really help me out. Thanks for reading.

    ow3n

  2. #2

    mac57's Avatar
    Member Since
    Apr 29, 2006
    Location
    St. Somewhere
    Posts
    4,560
    Specs:
    iMac 27" 3.4 GHz, 256 GB SSD, 2 TB HDD, 8 GB RAM
    Hi own3n, sorry to hear that you are having issues, but first things first - welcome to Mac Forums!

    Now, about that problem...

    When you say that things coming off the drive are corrupted, can you provide more details? What is the format of the external drive? How is the data corrupted? What kind of files are they, and what is leading you to the statement that they are getting corrupted as they come across? Did this all used to work before the upgrade?

    Since you say the drive works, but data off it is corrupt, I can assume that it mounts OK on the desktop, so the drive and the ports seem to be working. Do you have any other USB devices that you can try on those ports (a memory stick or something like that)? This would help to see if it is the port or the drive.

    This isn't an answer for you, just more questions, but getting over issues like this is often a process. Hopefully these questions, and their answers, are the first step of the process. Post back and we will work through it together.
    My Macs: iMac 27" 3.4 GHz, Mac Pro 3.2 GHz, PowerMac G5 Quad 2.5 GHz, G4 Cube with 1.2 GHz Upgrade
    My iStuff: 64GB iPhone 5, 64GB iPad4, 30GB iPod Video, 16GB iPod Touch
    My OS': Mac OS X Lion, Mac OS X Snow Leopard, Mac OS X Tiger, Mac OS 9.2.2, openSUSE 10.3
    I was on the Mac-Forums honor roll for September 2007

  3. #3


    Member Since
    Feb 22, 2007
    Location
    Minneapolis
    Posts
    3
    Specs:
    PowerBook, MiniMac
    Well why I think it's a firmware issue is because it worked previously (before the update). I tried all the Firewire ports, Monitor ports, computers port, and the money shoot another computers ports. It only works if it hooked up to another computers ports.

    Type of Drive: MicroNet 100 gigish.

    Data being corrupted: First and formost I'm a graphic designer so the extensions you here are going to be for that. I notice that in tiffs I would get scan lines on the raster art. I haven't tried every file format but they just won't open, Give me an error. At this time I can't remember the error sorry. The drive is hooked up to another computer now, until I get this figured out. I'll have to try the flash drive later. I'll let you know.

  4. #4

    mac57's Avatar
    Member Since
    Apr 29, 2006
    Location
    St. Somewhere
    Posts
    4,560
    Specs:
    iMac 27" 3.4 GHz, 256 GB SSD, 2 TB HDD, 8 GB RAM
    OK, let us know. As soon as we have some more info to work with, we may be able to help.
    My Macs: iMac 27" 3.4 GHz, Mac Pro 3.2 GHz, PowerMac G5 Quad 2.5 GHz, G4 Cube with 1.2 GHz Upgrade
    My iStuff: 64GB iPhone 5, 64GB iPad4, 30GB iPod Video, 16GB iPod Touch
    My OS': Mac OS X Lion, Mac OS X Snow Leopard, Mac OS X Tiger, Mac OS 9.2.2, openSUSE 10.3
    I was on the Mac-Forums honor roll for September 2007

  5. #5


    Member Since
    Feb 22, 2007
    Location
    Minneapolis
    Posts
    3
    Specs:
    PowerBook, MiniMac
    Well tried the USB Stick Drive and it works. I also realized another I haven't had sound on my mpegs since I updated the firmware. I think I royally screwed up. Do you think it would be good for me to bring it in to my tech guy? I've been putting that off cause he'll take it for awhile. Any thoughts?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to connect canon camcorder to fireware 800
    By josefcarel in forum Movies and Video
    Replies: 1
    Last Post: 07-17-2011, 08:21 AM
  2. Wireless card updated drivers/firmware
    By djlanky in forum Running Windows (or anything else) on your Mac
    Replies: 1
    Last Post: 02-17-2009, 03:26 PM
  3. Updated firmware?
    By bdevine in forum Apple Notebooks
    Replies: 3
    Last Post: 11-30-2007, 12:03 PM
  4. issues with superdrive firmware update?
    By otjatt in forum Switcher Hangout
    Replies: 3
    Last Post: 07-18-2007, 10:10 PM
  5. Firmware, keyboard, and boot camp issues
    By kuryis in forum Apple Notebooks
    Replies: 0
    Last Post: 01-15-2007, 11:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •