Results 1 to 3 of 3
  1. #1


    Member Since
    Jan 25, 2007
    Posts
    2
    Question is my iMac 400 slot load dead?
    I've changed out the motherboard, ram, hard drive and all I get when I press the power button is a momentary green flash & hd spin up & then nothing...is my mac dead?

  2. #2

    SpindleX's Avatar
    Member Since
    Jan 04, 2007
    Location
    Asheville, NC
    Posts
    80
    Specs:
    iMac Alum 20'' 2.4GHz | iMac G4 | iPod Silver Nano 2GB
    PAV board might be the culprit.

  3. #3


    Member Since
    Jan 25, 2007
    Posts
    2
    Question PAV Board HUH?
    Never heard of it...so I did some quick investigating & found out it has something to do with the CRT & I probably should let someone else handle this...:doctor:

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 07-04-2011, 06:05 PM
  2. Street Find..Slot Load Imac
    By Mac SK in forum Apple Desktops
    Replies: 20
    Last Post: 05-26-2010, 12:01 PM
  3. slot load 2001 imac
    By ki99 in forum Apple Desktops
    Replies: 2
    Last Post: 08-21-2007, 01:20 PM
  4. iMac 350 Slot Load Modem Problem
    By DakRoland in forum Apple Desktops
    Replies: 6
    Last Post: 02-12-2005, 12:59 PM
  5. imac slot load cd-r drives??
    By Texasmeat in forum Apple Desktops
    Replies: 1
    Last Post: 03-26-2004, 01:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •