Hello, new to the forum and macs so any help, advice would be greatly appreciated.

I have a problem logging into a power mac g5 I bought off eBay.

It takes ages for the login screen to appear and when it does it will not accept any user names or passwords. it initially worked then the system would not log off, when i did a hard power down and restart (using the power button) the error started occurring.

I ran the file system checker in single user mode, it found a couple of errors and corrected them. Now when I boot in single user mode it comes up with the following errors.

localhost netinfod [various number] start service_failed
localhost netinfod [various numbers] file init_failed: remote system error
memberd [76] - couldn't find root user

It continues in this vein, going to sleep then trying again in a permanent loop. Think I got the info correct.

Is this likely to be a hard drive fault? Is it looking for information off a server?

Will this require a complete re-install of the OSX 10.4?


Also, will any DVD drive work on the system of does it have to be a specific Apple compatible one, as the DVD drive that came with it appears to be broken?