My imac used to always connect to my wireless home network but strangely after it shuts down and restarts or when it sleeps and then awakens it loses the wireless connection. I will actually have to click on the airport icon by the clock and select my home network.

My home network is the preferred network in my system preferences so I'm not sure why it won't auto reconnect.

Any advice on how I can make it ALWAYS auto connect to my home network?