New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Desktops Discussion of Apple's desktop machines including Mac Pro, iMac, Power Mac, and mini

iMac - Help! My iMac is broken


Post Reply New Thread Subscribe

 
Thread Tools
Slowleg

 
Member Since: Jul 28, 2006
Posts: 17
Slowleg is on a distinguished road

Slowleg is offline
Today i went to wake up my iMac from sleep and it wouldn't start. Eventually i got mad and manually restarted it. It was working fine till i used expose and it suddenly froze with like a checkerboard pattern on the screen. I let it sit for awhile and nothing happened so i restarted it again and at start it has this checkerboard pattern. ( its hard to describe, its like multiple color fuzz and the regular background squares). The iMac wont start it just sits there with the display all messed up. I am running a 20 inch Intel imac. Please help me.

20 inch iMac 2 ghz 2 gigs 256 mb vram
500 mhz green machine iMac
1 gig nano
60 Ipod photo
I love my collection
QUOTE Thanks
novicew

 
novicew's Avatar
 
Member Since: Jan 04, 2006
Location: Hamburg, Germany
Posts: 1,385
novicew is a name known to allnovicew is a name known to allnovicew is a name known to allnovicew is a name known to allnovicew is a name known to allnovicew is a name known to allnovicew is a name known to all
Mac Specs: MacBook Pro | iMac(2.1 G5) | MacBook(2.16 C2D) | MacMini (1.67 CD) | iPhone 4 | iPad (3rd Gen)

novicew is offline
Have you tried to reset PRAM? Do the hardware test and report back with your findings.
QUOTE Thanks
Slowleg

 
Member Since: Jul 28, 2006
Posts: 17
Slowleg is on a distinguished road

Slowleg is offline
Tech support told me it is the video card. Im getting a new one. I hope they will let me get the nVidia 7300 GT this time.

20 inch iMac 2 ghz 2 gigs 256 mb vram
500 mhz green machine iMac
1 gig nano
60 Ipod photo
I love my collection
QUOTE Thanks

Post Reply New Thread Subscribe


« got my pro yesterday! | 20" iMac or Mac Mini »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Apple Pulls Plug on Original iMac schweb Apple Rumors and Reports 7 09-13-2006 05:38 PM
The New iMac (merged) EDIT-XTREEM Apple Desktops 7 07-21-2006 05:29 PM
Is it worth to switch from iMac G4 to iMac G5?? Mainyehc Apple Desktops 12 03-13-2006 07:21 PM
Help this IMac is broken Kermit1818 Apple Desktops 11 12-03-2003 07:34 AM

All times are GMT -4. The time now is 06:47 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?