New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Desktops Discussion of Apple's desktop machines including Mac Pro, iMac, Power Mac, and mini

My Compact Flash Card Reader won't mount anymore


Post Reply New Thread Subscribe

 
Thread Tools
SpideyPhoto

 
Member Since: Nov 01, 2012
Location: Woking, Surrey, UK
Posts: 2
SpideyPhoto is on a distinguished road
Mac Specs: 21" iMac, 2.5 GHz Interl Core i5, 4GB RAM, Harmon Kardon Sound Sticks 2, Crossfire ext HDD.

SpideyPhoto is offline
Hi

My USB CF (Compact Flash) Card reader is not mounting on my 2.5 GHZ Intel Core i5 iMac anymore.

Last week it worked fine to get pictures from my camera but now it won't mount at all.
I ejected it in the correct way rather than just disconnecting it but now i cannot get it to remount!
I cannot even see it in the disk utility or system profiler.

I have tried another card reader (a brand new one bought today) and the same problem exists. I've also tried different cards to see if that made a difference and they still arent being picked up on the Mac.

I have done all the usual things like rebooting, unplugging all other USB devices and then trying but nothing has worked.

I'm a photographer and I'm at my wits end here. I know the cards are fine as i have been using them without issue and they are also new.

Note: If I plug the camera in directly to the Mac, the Mac picks it up just fine as it always has done. Its just the card readers that it wont pick up anymore.

If anyone has any ideas at all other than the following (my so called friends advice) you'd earn my undying love:

Buy a PC
Use the camera (Thats why i bought the reader in the first place - importing RAW files from the camera is SLOW!)
Replace your CF cards (I have three 8GB cards two of which i had never used til today and they dont work either!)
Buy a new card reader (this is the 5th one in two days - none work on the Mac)

Many thanks in advance!

LIsa
QUOTE Thanks
SpideyPhoto

 
Member Since: Nov 01, 2012
Location: Woking, Surrey, UK
Posts: 2
SpideyPhoto is on a distinguished road
Mac Specs: 21" iMac, 2.5 GHz Interl Core i5, 4GB RAM, Harmon Kardon Sound Sticks 2, Crossfire ext HDD.

SpideyPhoto is offline
Seriously does nobody know? There have been LOTS of views on this and no one seems to know. Even on the Apple forums all they suggested was a multiple PRAM and SMC reset and this didn't work either.

I am at my wits end here and don't know what to do other than junk the Mac and get something else. Its making me that annoyed now!

No I won't buy a PC because I don't want to be asked 300 times if I am sure I want to do something when I tell you to do something.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 40,103
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
An SMC reset should have cured it. But since it obviously didn't, the only thing I can suggest is to contact Apple and have them look at it. Your iMac is a late model and may still be covered by Apple care. Is it?

Have you recently installed any new software or updated something that could possibly interfere with mounting the CF card reader? If other USB devices are being picked up correctly by the iMac, it may be software related.
QUOTE Thanks

Post Reply New Thread Subscribe


« iMac A1311 hardware questions | Apple Raised the Price on Refurbished 2011 iMac »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Transfering photos TO the iPad from a card reader using the camera connection kit. Doug b Images, Graphic Design, and Digital Photography 6 02-09-2012 11:10 PM
Dynex card reader issues Bailey Other Hardware and Peripherals 3 06-28-2010 10:45 PM
My new USB Card Reader dont mount. Tassos Other Hardware and Peripherals 1 04-08-2010 12:59 PM
N-gage MMC doesn't mount on desktop anymore koert Other Hardware and Peripherals 3 03-31-2005 05:37 AM

All times are GMT -4. The time now is 08:28 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?