New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Desktops Discussion of Apple's desktop machines including Mac Pro, iMac, Power Mac, and mini

MY iMAC IS RUNNING LIKE A SNAIL


Post Reply New Thread Subscribe

 
Thread Tools
AFMRPCUSER

 
AFMRPCUSER's Avatar
 
Member Since: May 10, 2012
Posts: 19
AFMRPCUSER is on a distinguished road

AFMRPCUSER is offline
I have been a Mac user for about 4 years now. I own a Mac Pro that I use for my Photography Business and several iMacs for other purposes, One for Amateur Radio Communications and one for Engineering Purposes and some Photography. One of my iMacs is running very slowly. It has always been extremely fast this one I also use for personal Photography... but, about a month ago I noticed it was taking very long to upload RAW photo images and when I load these RAW images into Photoshop CS4 or Lightroom it takes forever to load them. I have run some of the Disk management and test routines but I cannot figure out what is wrong. My other machines seem to be fine. This machine consists of the following.

OS X V 10.6.8
Intel Core 2 Duo 3.06 GHz
1.1GHz Bus Speed
Memory 4 GB RAM
500GB Internal HD
1-TB WD External USB Interfaced Hard Drive

Suggestions & Advice are most welcome.

Cordially,


Don

QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,731
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.10, iPhone6, iPad Air, AppleTV2

mrplow is offline
Not sure what you have tried so far but try these:
Run Disk Repair and Repair Permissions from Disk Utility
Download and run the automated scripts in Onyx for Snow Leopard
Reset your PRam Resetting your Mac's PRAM and NVRAM

Make sure you have free space on your internal Hard Disk - I'd suggest at least 20GB
Check to see that you don't have any unnecessary/memory hogs running on startup (System Preferences - Users Accounts - Login Items)

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks
AFMRPCUSER

 
AFMRPCUSER's Avatar
 
Member Since: May 10, 2012
Posts: 19
AFMRPCUSER is on a distinguished road

AFMRPCUSER is offline
Thank you mrPlow for your prompt response and the information... I appreciate this.

Don

QUOTE Thanks

Post Reply New Thread Subscribe


« Is my hardware good enough? | Macintosh 512K help »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
iMac 27 inch hum/buzz/vibration Jus_75 Apple Desktops 16 12-13-2012 05:44 PM
help with imac running tiger! runs so slow all of a sudden! jennefur8675 OS X - Operating System 13 09-18-2011 06:26 PM
Is my Imac capable of running Leopard? Fitchley OS X - Operating System 6 01-29-2009 04:18 PM
My iMac Running Windows XP Doesn't See USB Hub CessnaFlyer Switcher Hangout 2 01-09-2009 11:24 PM
Running iMac off AQUOS @ 1080p? Oversan P.I.T.A.! i-VTEC Apple Desktops 0 12-13-2006 12:10 AM

All times are GMT -4. The time now is 12:17 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?