New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Desktops Discussion of Apple's desktop machines including Mac Pro, iMac, Power Mac, and mini

New iMac internet goes out after a few minutes


Post Reply New Thread Subscribe

 
Thread Tools
spoof3r

 
Member Since: Oct 09, 2011
Posts: 1
spoof3r is on a distinguished road

spoof3r is offline
Hello everyone, Last night I purchased ab iMac and joined your side. I love it, but am having a few issues. I am able to identify my home network and connect to it. After I connect to it, I have Internet access. However, after i leave and come back after 15 minutes or so the Internet no longer works. It shows I am still connected to the wireless network, but Internet pages fail to load. If I disconnect from the network and reconnect to it, the Internet works again but it's the same story over and over again.

DHCP is enabled, and nothing else seems off. Obviously something is right because I have network and Internet access at first. Does the iMac have some weird settings I'm not seeing? I have searched forums and solutions but to no avail.

Seems like Mac and I aren't getting off to a good start...
QUOTE Thanks
gsahli

 
Member Since: Dec 11, 2010
Posts: 1,008
gsahli is a jewel in the roughgsahli is a jewel in the roughgsahli is a jewel in the rough

gsahli is offline
Turn off iPv6 and PPPoE if these are on.
QUOTE Thanks
pendlewitch

 
Member Since: Sep 10, 2011
Location: Nelson,UK
Posts: 1,737
pendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of light
Mac Specs: iMac 27" Mid 2010, 3.2GHz Intel Core i3,4GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Mavericks 10.9.1

pendlewitch is offline
There are known issues with 'sleep' mode disconnecting the wireless. There is lots of stuff on the internet about the issue because I have the same problem with a new iMac 27"..check what your time-out settings are in your preferences and adjust to a longer period if necessary. I have found that letting the machine find it's feet again for a while after waking up will re-connect.

You can also try disconnecting and re-connect your wireless router via it's own portal..you need to find it's own ip address in your network settings and list it as a top site in Safari so that you can readily access it..I wouldn't recommend dropping the power to your wireless router on a regular basis although it does help to perform a reset occasionally.

The router should also give you an option to do a firmware update, so do this as soon as possible.

Also check your wireless router position, it needs to be as close to your machine as it can be or centrally at a high point to your dwelling.

Apart from that it's a pain in the butt.

iMac 27-inch Mid 2010, WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
iPhone 5C, iPod Nano 4GB 3rd Gen,ATV2, Samsung LE40 Series 6, Denon AVR1910, Kef HTS 1001.2s and Kube-1 Sub
Denon DCD510AE, Panasonic DMP-BD60,Sky+HD,Logitech Harmony One Advanced. MOTM October 2012.
QUOTE Thanks
pendlewitch

 
Member Since: Sep 10, 2011
Location: Nelson,UK
Posts: 1,737
pendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of light
Mac Specs: iMac 27" Mid 2010, 3.2GHz Intel Core i3,4GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Mavericks 10.9.1

pendlewitch is offline
iMac disconnects from wireless - MacRumors Forums

This link may help...I'm going to have a closer look at the WEP issue.

iMac 27-inch Mid 2010, WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
iPhone 5C, iPod Nano 4GB 3rd Gen,ATV2, Samsung LE40 Series 6, Denon AVR1910, Kef HTS 1001.2s and Kube-1 Sub
Denon DCD510AE, Panasonic DMP-BD60,Sky+HD,Logitech Harmony One Advanced. MOTM October 2012.
QUOTE Thanks
Chef_eam

 
Chef_eam's Avatar
 
Member Since: Dec 12, 2009
Location: Midland,Tx
Posts: 357
Chef_eam is a jewel in the roughChef_eam is a jewel in the rough
Mac Specs: iMac 27" 2.66GHz i5, 1TB HDD, 12GB RAM, OS X 10.7.3, iPod Classic 160GB,iPad 1 64GB Wi-fi, iPhone 4S

Chef_eam is offline
My iMac did the same thing when I first got it. I was using a Belkin N+ router at the time. When I purchased an Airport Extreme, the problem went away, and I have also never has a problem with it staying connected to a Linksys router.
QUOTE Thanks
pendlewitch

 
Member Since: Sep 10, 2011
Location: Nelson,UK
Posts: 1,737
pendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of light
Mac Specs: iMac 27" Mid 2010, 3.2GHz Intel Core i3,4GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Mavericks 10.9.1

pendlewitch is offline
Quote:
Originally Posted by Chef_eam View Post
My iMac did the same thing when I first got it. I was using a Belkin N+ router at the time. When I purchased an Airport Extreme, the problem went away, and I have also never has a problem with it staying connected to a Linksys router.
Yes I had heard that certain wireless routers were Mac specific..mine's Belkin 54G and the firmware update is obsolete.

iMac 27-inch Mid 2010, WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
iPhone 5C, iPod Nano 4GB 3rd Gen,ATV2, Samsung LE40 Series 6, Denon AVR1910, Kef HTS 1001.2s and Kube-1 Sub
Denon DCD510AE, Panasonic DMP-BD60,Sky+HD,Logitech Harmony One Advanced. MOTM October 2012.
QUOTE Thanks

Post Reply New Thread Subscribe


« iTunes staying at home desktop in lion???? | Using 2 Identites on iMac at same time »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
wireless internet connection issues with iMac kris.richter Internet, Networking, and Wireless 3 06-10-2011 02:50 PM
iMac bridge to Directv dvr for internet connection chicolonga Internet, Networking, and Wireless 2 05-20-2011 02:01 PM
Connect iMac to MacBook Pro via Internet?? skgshepherd OS X - Operating System 3 05-05-2011 09:06 PM
Imac 27" internet connectivity issues oposky2006 Apple Desktops 0 02-27-2010 01:06 AM
iMac G4 and AEBS Internet issues mojo69 Internet, Networking, and Wireless 31 11-16-2009 08:05 PM

All times are GMT -4. The time now is 09:07 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?