Results 1 to 3 of 3
  1. #1

    Member Since
    Mar 14, 2010
    trouble disabling EFI password, accessing prompt
    Hi, Iíve been experiencing some fan spin-up issues on my Mac Pro 1,1 (late 2006 1st gen. Intel model). After posting at, I was encouraged to run Apple Hardware Test to test for any hardware faults. Unfortunately, ever since I set up a firmware password -- to prevent tinkerers/younger brothers/etc. from messing around with my computer -- Iíve had troubles disabling that firmware password temporarily, so as to run the Apple Hardware Test.

    As you will know, setting up a firmware password prevents booting the computer from external media (for example, from the OS X system CD/DVD), or flashing the PRAM, amongst other things. I spent a couple hours last night trying to disable my EFI password temporarily, and couldnít! According to Apple's documentation, the user must reboot their computer while depressing the Option key to pull up the EFI password prompt. When I do that, my Mac Pro appears to start the boot process normally (all the ordinary spin-up sounds of hard drives/fans/etc.), but the monitor never illuminates, and the boot process seems to stall. If I press the power button to re-boot, the machine shuts down immediately, without requiring a "hard" reboot.

    Has anyone else witnessed this scenario? I HAVE tried removing the firmware password by navigating to ď/Volumes/Mac OS X Install DVD/Applications/Utilities/Ē on my OS X Snow Leopard retail DVD, and running Firmware Password Utility. The same thing still happens when I Option-boot, though.

    Is it possible that my EFI password prompt DOES come up, but ISN'T being displayed on screen? I have noticed that since I purchased a new graphics card (the ATI Radeon HD 5770 graphics card, a replacement for an nVidia GeForce GT 8800 for Mac, that "burnt out" a couple months ago from excessive use, I guess), my screen remains blank right up until the end of the boot process. Maybe the updated OS X boot ROM doesn't initialize the new graphics card early enough in the boot process to view the EFI password entry prompt, or some-such thing?

    Does anyone know of ANY OTHER WAY besides depressing the Option key during boot to access the EFI password prompt, so as to temporarily disable it? I will call Apple Corp. and ask them if I have to, but I canít stomach their Apple Care tech. fees for out-of-warranty Apple products.

    Thanks for any help you can offer!
    -jabroni5 (that guy who insists on coddling his 5-year old Mac Pro instead of upgrading)

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Welcome to the Mac Forums.

    There's something going on with your EFI Firmware password that's not correct. It should respond exactly as Apple described in the KB article. The only thing I can suggest it to try to force remove it by using this method:


    Once you get it removed, I suggest not using it again. Lock up your boot disks and the computer if necessary to keep meddling hands off it.

  3. #3

    Member Since
    Mar 14, 2010
    Thanks chscag. I followed your advice and it worked perfectly.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Prompt for Password
    By lay9eggs in forum Apple Notebooks
    Replies: 2
    Last Post: 12-28-2010, 03:14 AM
  2. username password prompt - do not want
    By asdf in forum Web Design and Hosting
    Replies: 2
    Last Post: 03-09-2009, 10:21 PM
  3. safari password prompt
    By variz in forum OS X - Apps and Games
    Replies: 0
    Last Post: 02-01-2009, 09:06 PM
  4. Will not prompt for username and password
    By NeoGreen in forum OS X - Operating System
    Replies: 2
    Last Post: 01-03-2008, 10:37 AM
  5. WEP password prompt
    By mugglecox in forum Switcher Hangout
    Replies: 1
    Last Post: 12-02-2007, 04:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts