Results 1 to 3 of 3
  1. #1

    Member Since
    Apr 14, 2011
    Need urgent help on Sawtooth stucked at Open Firmware screen

    I've got a G4 Graphite Sawtooth Powermac running a Newertech MaxPower 2.0MHZ processor upgrade for about 3 years. It is running Leopard (10.5.8) system.
    I've also installed a Seritek 1S2 card with a 500GB Sata disk.

    Some days ago I've started to notice that sometimes when I did Log Off or Shut down the Mac cleaned all the desktop icons but then nothing happens.
    Also, it started to freeze sometimes doing some tasks like open apps or working on Photoshop.
    Today the Mac refused to boot on the main system disk (I have a secondary 80GB disk with Tigger installed on it).
    Then I ran TechTool Pro Disck scan and it gave me an error on scanning the main disk.
    I've booted into the Tiger disk (a 80GB one) and think to myself if this could be something to do with the Seriteck card or driver, or something related to it...
    I've loaded the Seritek install CD and click the install firmware of the Seriteck disk, then I've booted and... it stucked on Open Firmware forever.
    It is on the welcome screen of the open firmware and I can't do anything.
    It says" To continue booting, type "mac-boot" and press return", but I can't type anything because it looks freezed and my keyboard don't respond.

    I've tryed the firmware boot (that one with the long beep pressing the programmer button) at no avail.

    Tried to remove the battery from mainboard.
    Tried to reboot from install disk pressing option+command+shift+delete.

    I'm desesperate. I'm a freelancer and I've goot importante work to deliver to clients and I can't get my Mac to to boot into the system.

    At this point I just want to boot normally into Tiger, Leopard, whatever.
    I just need to boot and recover my works.

    See screenshot of Open Firmware screen here:
    ImageShack® - Online Photo and Video Hosting

    Can someone please help?

    Thank you for your time,

  2. #2

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Nambucca Heads Australia
    iMac i5 2.7GHz, 16GB memory, OS 10.11.1.
    Remove the Seritek card and the SATA drive. Never had much joy with them back in G4 days with a 1.25GHz FW800 MDD. Think from your description either the card or the drive has failed. The 80GB drive is installed in the G4? You may have to install leopard on that.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  3. #3

    Member Since
    Apr 14, 2011

    thank's for your replay!
    I'm getting something...

    Yes, the 80GB disk is the original main disk and have Tiger installed on it.

    I've removed the Seritek Sata card and system rebooted without stuck in the open firmware’s default catch screen

    After an initian long waite I managed to finish boot and load Tiger.

    I then tryed again to connect the Sata disk and the Seritek card but again comes the Open Firmware screen.
    So, it's prooved to be something with the Sata card or disk.
    It is not the cable (I've tested with another one).

    Could be the Seriteck card damaged, or it is needing some new drivers?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Urgent: MBP stuck in firmware update?
    By Calundann in forum OS X - Operating System
    Replies: 0
    Last Post: 05-16-2011, 06:43 AM
  2. G4-grey screen no spinning thing- can open in firmware
    By Heathabee in forum Apple Desktops
    Replies: 1
    Last Post: 07-02-2009, 08:30 PM
  3. Replies: 2
    Last Post: 10-06-2007, 05:28 PM
  4. G4 Sawtooth AGP - USB problem at startup / firmware
    By kay_mac in forum Apple Desktops
    Replies: 8
    Last Post: 04-21-2007, 07:02 PM
  5. Sort've urgent: Keyboard for Sawtooth G4..PS/2..USB
    By ckboddic in forum Apple Desktops
    Replies: 2
    Last Post: 08-03-2006, 08:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts