Background: I think there are two problems, back to back, that may be contributing to my problem. First; a year ago my Mac mouse died so I installed the soft ware for a Kensington Track Ball and it has been wonderful. It is not designed for mac, therefore, I suspect it may be part of the whole ball of wax. Not sure as it worked well for all the time I have had it working.

Second, I got a Canon PIXMA 870 printer for Christmas and I had to stop the install, with CD, half way through as I couldn't find the info for the wireless connection. (Wireless is the Apple Airport Xtreme router). I have the Pixma icons on my desktop and the doc, have found the wireless info but am considering uninstalling the Canon printer software and starting over, fresh. I also updated to Snow Leopard a couple months ago.

That said, my problem is that the mouse won't scroll with the track ball, when this occurs. It will with the cursor. When this occurs I cannot get to disc utilities without the desktop freezing. I have to force quit, restart and run fsck -fy, usually twice, to get the hard drive appears to be ok message.

I want to reiterate that the track ball has worked fine since connection last year. Narry a problem. This happened after I had to stop the pixma install and have had to force quit and restart at least 5 times in the last 3 weeks.

Any suggestions or help? I have retired from my photography and am free of all but my most important clients so I would like to work with you to figure out what I did wrong. Thanks for being on the net to help. Macro