Results 1 to 2 of 2
  1. #1

    Member Since
    Nov 16, 2010
    Question Macbook pro screen only turns on when external monitor is plugged in
    I installed a trial version of SwitchResX to increase the resolution of my external monitor to the correct resolution, but that wasn't working the way I wanted it to and I uninstalled it. So as of now, I'm using my external monitor at a lower resolution that what it's capable of (this is fine and currently the least of my worries).

    The problem I'm having now is that when I unplug my external monitor, my Macbook Pro's screen goes "blank" but is still on (the lights are still on and just appears black). The MBP monitor is not broken, as the screen comes back when I plug in my external monitor. Even when I turn off the computer and start it up without the external, the startup screen appears black as well. But when I plug the external in, everything is fine.

    How do I fix this?

  2. #2

    Member Since
    Nov 16, 2010
    Oh I figured it out. The resolution for when my external wasn't plugged in was causing my mbp to be at a resolution that wouldn't work (causing the black screen). I plugged in my external monitor, opened up the display options and made sure my cursor was near the resolution options. After unplugging my external, I just clicked and used the arrow keys to change the resolution back to its original, causing the screen to come back again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Macbook Air 11"Mid 2013 Turns on by itself when plugged in
    By pablotech in forum Apple Notebooks
    Replies: 2
    Last Post: 05-20-2015, 07:22 PM
  2. Replies: 6
    Last Post: 06-16-2013, 03:11 PM
  3. Replies: 8
    Last Post: 12-28-2012, 03:35 PM
  4. Problems with MacBook pro when plugged into external display
    By Djroonsteruk in forum Apple Notebooks
    Replies: 11
    Last Post: 01-27-2011, 08:48 AM
  5. Nano turns on when plugged into wall, but screen is blank
    By Tanner31593 in forum iPod Hardware and Accessories
    Replies: 1
    Last Post: 01-27-2008, 08:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts