Results 1 to 4 of 4
  1. #1

    Member Since
    Aug 15, 2009
    Unable to find driver for this platform "PowerMac2,1" - error with no solution?
    Hello dearest members.

    I have a big issue. My little brother got an iMac G3 as a present, to play basic games on it. It had MacOS 9.2.1 installed and the firmware was updated to the latest version. I installed MacOS X 10.4 and it worked flawlessly up till now. All of a sudden, after booting, error screen appears, and I haven't been able to fix it.

    I've tried:
    • booting from MacOS 9.2.1 install disc
    • booting from MacOS X 10.4 install disc
    • resetting PRAM and NVRAM
    • booting into safe mode
    • booting into single user mode

    This is the error code:

    Is there anything I can still try?

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    That's a pretty old machine. It could need a new PRAM battery as it's possible that it still has the original which might be dead. Not sure where you can get a PRAM battery for it but if you have the original manual it might tell you which one you need. Or, you could open the machine and find out that way.


  3. #3

    pigoo3's Avatar
    Member Since
    May 20, 2008
    2011 13" MBP 2.3ghz, 8gig ram, OS 10.7.5
    If your computer needs a PRAM's probably this one:

    3.6v Newer Technology Lithium 1/2 AA PRAM Com... (3.6VPRAM) at OWC

    - Nick

  4. #4

    Member Since
    Aug 15, 2009
    Yeah, the PRAM battery is still the original one. Thanks for the link, but I've found some European Newertech retailer, to cut down the shipping costs.

    I'll report back when I have the new PRAM battery ...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 10-04-2015, 01:28 PM
  2. Unable to copy files to external HD without "file in use" error
    By theroux in forum OS X - Operating System
    Replies: 8
    Last Post: 12-09-2012, 10:27 AM
  3. Error Message: "can't find the the harddrive"
    By MackyB00k in forum Apple Desktops
    Replies: 2
    Last Post: 03-24-2009, 05:19 AM
  4. Replies: 6
    Last Post: 02-18-2009, 03:19 AM
  5. Possible Solution for "Bluetooth Unavailable" error
    By morgul in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 09-07-2007, 05:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts