New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Desktops Discussion of Apple's desktop machines including Mac Pro, iMac, Power Mac, and mini

Power Mac - help w/old OS X


Post Reply New Thread Subscribe

 
Thread Tools
jakjkl

 
Member Since: Sep 26, 2008
Posts: 8
jakjkl is on a distinguished road

jakjkl is offline
I just got a g4 w/10.3.9 Yeah I know its old, but I got it for free, and I like it. My question is, can I update the version of OS X? I need to upgrade my browser, and I cant without upgrading my OS X. This old safari keeps quiting on me, please help!
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 18,107
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz, 16GB memory, OS 10.10.1

harryb2448 is offline
Don't post twice and look at other post for reply.
QUOTE Thanks
hughvane

 
hughvane's Avatar
 
Member Since: May 18, 2008
Location: Banks Peninsula, New Zealand
Posts: 3,263
hughvane is just really nicehughvane is just really nicehughvane is just really nicehughvane is just really nicehughvane is just really nice
Mac Specs: MacMini 2.4, 4 Gb, OS 10.9 and 10.6; MacBook 2.4, 2 Gb, OS 10.6.8

hughvane is offline
Quote:
Originally Posted by jakjkl View Post
I just got a g4 w/10.3.9 ... can I update the version of OS X? I need to upgrade my browser, and I cant without upgrading my OS X. This old safari keeps quiting on me, please help!
Are you determined to keep using Safari? If not, then Firefox 2 (free) works just fine with OS 10.3.9. If you're sure you want to upgrade the OS you'll need to buy the retail version of Tiger. Make sure you put maximum RAM in that G4, you won't regret it.
QUOTE Thanks
MacGenius24

 
MacGenius24's Avatar
 
Member Since: Feb 15, 2008
Location: Brampton
Posts: 33
MacGenius24 is on a distinguished road
Mac Specs: PowerBook G4 ,1.67 GHz,120 GB hard disk; Slot-Load SuperDrive DVD±RW/CD-RW

MacGenius24 is offline
Did you use software update? and safari normally closes when you try to do somthing that is ram and processor demanding. hughvane is right, you should get firefox but not 2, 3.

G4 1.33 GHz, 1.5 GB RAM, 60 GB Hard Disk, Slot-load SuperDrive (DVD-R/CD-RW). Mac OS X 10.5.6
G3 400 MHz, 512 MB RAM, 120 GB Hard Drive, Combo Drive (CD-RW/DVD-ROM), Mac OS X 10.4.10
QUOTE Thanks

Post Reply New Thread Subscribe


« Pentium 4 in G3...? | Como Drive Question »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 11:39 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?