Ok, so I have a friend of mine's G5 imac here that will not boot at all from anything. He tells me the last ting he did was plug his ipod into it after his mother accidentally washed it in his jeans, lol. Now, I can go Target Disk mode and use my Powermac g5 to access the drive. I managed to save all of his data and run diags on the disk. No problems reported at all. Disk read fine. Even formatted with write all zeros and reinstalled Tiger OS. Can start os from Power mac in Target disk mode but iMac will still not boot. Whther I try from CD or HD it will hang with the prohibitory sign and spinning gear. Hangs on Single User mode at "AppleSMU -- shutdown cause = 3", "still waiting for root device". Have reset PRAM. Have tried "c" and "d' for alternate boot route. Have removed third party RAM. Can go into Open firmware. Reset-nvram there. Still nothing. Thinking hardware issue. Maybe wet ipod fried something. Any ther ideas? Thanks in advance.

BTW cannot open iMac g5/2.1 isight for some reason, unless I am missing something.