New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Desktops Discussion of Apple's desktop machines including Mac Pro, iMac, Power Mac, and mini

eMac - emac display flicker etc


Post Reply New Thread Subscribe

 
Thread Tools
Connorregan

 
Member Since: Oct 03, 2007
Location: Dublin and London
Posts: 7
Connorregan is on a distinguished road
Mac Specs: G4 1.5 15

Connorregan is offline
Hi, I have an emac g4 that has a number of problems, It is a 1.25gz. Sometimes it will boot to a blue, blank screen, on holding down the alt key I see the boot drive and I can start up (10.4os) but will go to the blue screen again. When it does start up properly, which it does for no apparent reason, there are little dash shaped spots on the screen and a flashing horizontal flicker. I ran fsck and disk utility and installed a fresh version of 10.4 to no avail. I do not have the original disks so cannot run hardware test. The computer falls under the Apple emac screen repair but they will not accept it because it is out of the three year time limit, very frustrating and unfair. I read about an IVAD cable that can be replaced to repair the problem but am not sure if it is relevant to this problem. I would be very grateful for any ideas, thanking you in advance,
Connor
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 17,715
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz, 16GB memory, OS X.10

harryb2448 is offline
Many of the problems you describe are associated with the capacitor problem eMac 1.25GHz experienced. Disconnect from the power, open the inspection hatch and see if any of the capacitors are bulging and/or leaking.

Hope that is not it as the warranty repair expired when the unit was three years old, or in most cases July 2007. Here is a link:-

http://www.apple.com/support/emac/re...ensionprogram/
QUOTE Thanks
Connorregan

 
Member Since: Oct 03, 2007
Location: Dublin and London
Posts: 7
Connorregan is on a distinguished road
Mac Specs: G4 1.5 15

Connorregan is offline
Thanks for that Harry, I will have a look at the capacitors tomorrow, if this is the problem do you know of a fix? I will probably have the wherewithal and the tools to fix it if I can get ahold of a guide. Is there something I can find online? Thanks again,
Connor
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 17,715
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz, 16GB memory, OS X.10

harryb2448 is offline
Have a look first. Did post a link will look it up for you if necessary. Here is the link describing this probelm of slickering etc:-

http://emacproblems.blogspot.com/
QUOTE Thanks

Post Reply New Thread Subscribe


« Power Mac g5 help Panic error | Imac repair free plus free macbook charger! »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
eMac won't display anything Avenger2SER Apple Desktops 2 05-07-2008 08:39 PM
imac with mini-DVI to VGA no longer sees second display in leopard. scutteroz OS X - Operating System 5 02-10-2008 02:18 AM
Display Issue kako OS X - Operating System 0 06-29-2006 04:16 AM
Additional display for eMac? kill8joy Other Hardware and Peripherals 6 07-20-2005 09:25 AM
eMac Display Problem - Contrast? H3FC900s Other Hardware and Peripherals 5 04-17-2004 12:58 AM

All times are GMT -4. The time now is 06:58 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?