New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Desktops Discussion of Apple's desktop machines including Mac Pro, iMac, Power Mac, and mini

iMac - Optical out works not as expected


Post Reply New Thread Subscribe

 
Thread Tools
xcapepr

 
Member Since: Jul 10, 2007
Location: San Juan, PR
Posts: 39
xcapepr is on a distinguished road

xcapepr is offline
I finally got the mini Toslink adapter to use my 5.1 speakers with the new iMac.

The wierd thing is that the output seems to not be always on - when no audio is played, the reciever displays on the screen that no Optical data is recived. When an OS alert sounds, for example, a thump is heard from the speakers and there is a very short delay and then the end of the sound plays.

Once any sound plays, it displays it as 2ch, 96. When DVDs are played (I have set it to forward to optical out) I get full 5.1 sound then and the screen reads Dolby Digital, perfect.

Normal?

iMac 24' Penryn - 2.8Ghz, 1TB Seagate Baracuda ES.2, 4GB OCZ PC-6400
MacBook Pro 15' Memron - 2.2Ghz, 250GB WD Scorpio, 4GB OCZ PC-5300
iPhone 3G 16GB
QUOTE Thanks
goobimama

 
Member Since: Apr 28, 2006
Posts: 2,542
goobimama is a jewel in the roughgoobimama is a jewel in the rough
Mac Specs: iMac Core Duo 20", iBook G4, iPhone 8GB :)

goobimama is offline
That delay thing is always the case with Optical sound. Even when I switched from Coax to Optical for my Z5500, I got that same delay thing. Cause there is no optical data transmitted while there is no output.

As for upmixing that audio to 5.1, I hope there is such a tool for the Mac. Cause I'm dumping my PC to get one. Doesn't your receiver have a 5.1 upmix built in?
QUOTE Thanks
xcapepr

 
Member Since: Jul 10, 2007
Location: San Juan, PR
Posts: 39
xcapepr is on a distinguished road

xcapepr is offline
I have the Logitech Z5500 Digital. The LCD on the digital module reads "no optical data" and as soon as sound plays it reads whatever effect is set.

The strange thing is that when I disconnect the optical cable from the digital module the cable is not lit. If I play a sound with the optical cable disconnected, the cable remains lit even when the sound stops playing.

The Z5500 have built in 5.1 encoding and I can upmix the stereo output in Dolby Pro Logic music or movie.

iMac 24' Penryn - 2.8Ghz, 1TB Seagate Baracuda ES.2, 4GB OCZ PC-6400
MacBook Pro 15' Memron - 2.2Ghz, 250GB WD Scorpio, 4GB OCZ PC-5300
iPhone 3G 16GB
QUOTE Thanks
goobimama

 
Member Since: Apr 28, 2006
Posts: 2,542
goobimama is a jewel in the roughgoobimama is a jewel in the rough
Mac Specs: iMac Core Duo 20", iBook G4, iPhone 8GB :)

goobimama is offline
The Z5500 rules doesn't it! Anyway, I'm currently using the same thing on an Auzentech Xplosion soundcard via Optical and it gives that same delay problem. Annoying to say the least.

Not tried the disconnecting thing though.
QUOTE Thanks

Post Reply New Thread Subscribe


« CPUs are running at 30-50% each while doing practically nothing! | RAM question »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
MacBook Pro Optical Out KamileonX Music, Audio, and Podcasting 6 09-30-2008 04:55 PM
Looking for All-In-One printer that works with Leopard TaiTam Other Hardware and Peripherals 6 03-18-2008 12:38 PM
Odd and Unusual Optical Drive Problem. Help please? Deloreansyk Apple Notebooks 4 11-05-2007 02:30 AM
Divx videos with Optical Surround thunder3000 Movies and Video 3 10-29-2007 12:42 PM

All times are GMT -4. The time now is 11:13 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?