Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Apple Desktops (http://www.mac-forums.com/forums/apple-desktops/)
-   -   iMac is not booting, goes to firmware boot :O? (http://www.mac-forums.com/forums/apple-desktops/106106-imac-not-booting-goes-firmware-boot-o.html)

luiguiv 04-25-2008 07:24 PM

iMac is not booting, goes to firmware boot :O?
 
Hello everyone,

I recently bought a second hand iMac G3, 400MHz processor and 128mb ram, 10gb harddrive and it has as i suppose Mac OS 9.2. I've always wanted a Mac just for the fun of it, and i finally got it. I dont think this imac is dead, but i'm having trouble on boot. It is not booting the traditional way, it is going down to firmware boot.

It gives this info:

MacOS: Boot Failure! (0xF3C481F6)
Mac OS: parcel initialization failure - bad checksum

Then i have 2 choices from the firmware for booting or shutting down 1. mac-boot command and 2. shut-down command.

So, i give it the mac-boot command; in starts showing the mac face for a few seconds, then it displays this message below of it:

/pci@f2000000/mac-io@17/ata-4@1f000/disk@0:5,\\:tbxi

after maybe a minute it finally displays the face and ? symbol; typical of not finding the system. Problem is that, even starting the imac with the system disc on it and pressing "c" at bootime, it still goes to the firmware thing...

Is there a way to tell the imac "hey dont boot at firmware, boot at cd!!" ??

Oh, by the way...during the "/pci@f2000000/mac-io@17/ata-4@1f000/disk@0:5,\\:tbxi" message I can still press the "alt" key and it shows me the retry arrow, the system harddrive labeled "Lorelai's comp", the system CD and the straight right arrow.... i try clicking on the harddrive and also on the CD icons to try to boot, but it only refreshes the screen changing from the traditional blue/purple background to a red-ish background and arrow/drive's buttons get funny colors...

i dont know what is going on....i dont think the imac is dead....i guess it has to do with that firmware booting default thing...

please help....
thanks in advance.

Sherman Homan 04-25-2008 07:49 PM

Zap that pram: from a cold dead boot, hold down all four keys together:
apple option P R
You need to hear three start up chimes, then let go of the keys.
Pray!

luiguiv 04-25-2008 08:17 PM

hi,

it's not working...i pressed the four keys, but is only gives 1 chime, and then it goes back to the firmware screen... :S

by the way i tried a dir cd:,\ and a dir hd:,\ command and they both list me the cd for the first, and the hd for the second...

can i start the installation from there? how do i do that?

Sherman Homan 04-25-2008 09:49 PM

Hmmm, Plan B.
Roll it over, open it up. Pull the ram chip (you are going to need more of that stuff if this works!). Pull the battery, press the PMU button. Be careful there, pressing for too short a time doesn't do anything. Pressing too long can fry it, killing the motherboard. One second. Put it back together. More prayers!

luiguiv 04-25-2008 11:26 PM

Ok, done that....nothing.....

what happens if i repeat the procedure? will i still fry the logic board?

i powerred it up again, and nothing...samething, firmware stuff again...

any suggestions?

thanks.

luiguiv 04-26-2008 04:14 PM

Hi guys,

i finally managed to fix this thing, with some help from people at apple forums...the main thread is here

http://discussions.apple.com/thread....99849&tstart=0

So basically i found the problem...iMac ran out of firmware battery...it was dead and i wasnt aware of it..so i checked it and changed it with the one from the working iMac...also i did the PRAM reset procedure with the firmware console comands:

reset-nvram
reset-all

after the iMac restarted, there was a black screen..wasnt booting at all, so i was intrigued about the status of the main ram modules...i replaced them with the ones from the working iMac and at last! the iMac came to life :O:O:O

now i have to buy a battery and a ram module or two, but the main problem is solved...

thankyou all,

cheers,

luigui.


All times are GMT -4. The time now is 12:06 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.