View Single Post
mareeder

 
Member Since: Oct 23, 2009
Posts: 1
mareeder is on a distinguished road

mareeder is offline
Hi geniuses,

I have been using iMovie HD for quite some time now. (iMovie '08 was a huge step backwards in my opinion, and I hated it.)

But just this week, I opened iMovie HD and began my import process and it starting importing all my footage into one long clip, not separating them into "clips" as it always has.

I tried everything, to no avail, including reinstalling iMovie and re-importing. No such luck. Same issue.

So I finally loaded up iMovie '09, and have been pleasantly surprised by the improvements (but still no ability to add effect to video which upset me). But the same issue persists. iMovie '09 is importing all my footage as one long clip, no separation.

Now I have been importing and editing with the same combo of equipment for a few years now with no issues. My camera is a Hi/Digital 8 Sony Digital Handycam, firewired to an iMac Intel Core duo 2.1 ghz.

Why suddenly are things not working properly? Did I inadvertently flip some mysterious switch on my camera? Is the camera/editor combo suddenly obsolete? Why do things just stop working properly?

Terrible timing for this as I have some urgent editing projects that I need to get finished and soon.

Any advice?
QUOTE Thanks