View Single Post
Veshta777

 
Member Since: Oct 08, 2009
Location: Iowa
Posts: 1
Veshta777 is on a distinguished road
Mac Specs: Powerbook G4, Imac Intel

Veshta777 is offline
The original hard drive (80 GB) went bad, so I replaced with a new 160 GB Western Digital one. I formatted the hard drive using Disk Utility from the Mac OS X Disk. It worked the first time I booted into Leopard (I just booted up to make sure the OS loaded...didn't install any new software and/or hardware).

Then I shut it down and started it back up, and the computer didn't recognize the hard drive. I inserted the Mac OS X disk and ran Disk Utility, but the hard drive was not recognized.

So now I'm thinking the new hard drive was also bad. So, I ordered another one (Seagate 160 GB) and it to was not recognized when I ran Disk Utility from the Mac OS X disk.

When replacing all of them, I followed directions I found here and other websites. They all said to do it the same way, so I'm assuming the directions for replacing a hard drive in a laptop were correct.

I searched Google and found several posts suggesting using an application called Disk Warrior, but from my understanding, you cannot run it from a disk, it needs to be installed, which is obviously impossible since the hard drive isn't recognized.

Then I ran Open Firmware and did "devalias" from the prompt. From what I can tell in the list of hardware, the hard drive is recognized, but I am not sure. I took a picture of the screen here is the image URL: Pictures by Veshta777 - Photobucket

In the list, "hd" is in the left column and in the right column of the same line is "/pci@f4000000/ata-6@d/disk@0" (without quotes).

If anybody has any suggestions, they would be greatly appreciated.
QUOTE Thanks