View Single Post
hphoto

 
Member Since: Sep 22, 2009
Posts: 2
hphoto is on a distinguished road

hphoto is offline
Quote:
Originally Posted by lsusparks View Post
I noticed this same exact problem on my MacPro yesterday. It was never an issue before 10.6. Changing the ttl on the DNS server fixed it for me (not much help if you don't have access to do that).

Here's the deal - one of our networks at work had ttl's of 5256000 seconds. I had trouble browsing to web servers on that network. Most other addresses worked fine, but had much lower ttl's. I asked our DNS administrator to adjust the ttl on one problem address down to 604800 and suddenly the problem is gone (for that one address). Then I had him change all records to be no more than 604800 (an arbitrary number on my part, 7 days vs 60 before). It seems totally fixed.

If you're seeing this on a home network, check if your router is doing dns caching or anything like that. If possible adjust the ttl or turn off the DNS caching and see if that fixes it.

To check if maybe this is your problem, use Network Utility to lookup the name. You'll see a line like this:
myserver.me.com 43200 IN A 10.10.10.15
That 43200 is the ttl (time to live, in seconds). I know from experience that 5256000 is too high an causes problems in SL, and that 604800 does work. Where exactly it breaks I'm not sure.

I'm interested to hear if this fixes anyone else's problems.
Thanks for the hint. Same problem with my Macbook Pro after upgrade. Aside from sleep, applications will not resolve local domain hostnames after a few minutes after boot. Disabling and renabling DHPC in Snow Leopard would cure this problem until a few minutes later and same problem occurs.

Seems like Snow Leopard is not respecting DNS ttl value of 0 by not querying the DNS server? I use DNSMasq (in a dd-wrt router) and that is the ttl default for local domain hostnames. Use "dig myhostname any" to confirm. I modified DNSMasq ttl to 1 second by adding this option:
local-ttl=1

and I no longer experience this problem. I hope this information can help someone.
QUOTE Thanks