View Single Post
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 38,435
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
Quote:
Originally Posted by djames210 View Post
I have a new Canon Pixma MP620 printer and a new MBP with Snow Leopard upgrade. Does anyone know how to get the wireless printer to show up as an option for printing?

I tried to follow the Canon instructions. However, after about 2 hours of tring, I just can't get the setup to work. It's soooo frustrating...
Make sure you download updated Snow Leopard drivers from Canon or just use Software Update. It's probably best to use software update so they'll be downloaded automatically and placed in the correct folders on your Mac.

Then run the Canon wireless utility. The utility will actually use your router setup (SSID and password) to make contact with the MP 620. You should see two Canon MP 620 printers when you open the Printer Preference Panel. One will have a net address, the other will not. The one with the net address is your wireless printer. Use it as the default.

I have my MP 620 located about 20 feet from the router and it works fine. A bit slow at times when printing, but otherwise OK.

Regards.
QUOTE Thanks