View Single Post
prushik

 
Member Since: Jun 14, 2009
Posts: 14
prushik is on a distinguished road

prushik is offline
I have installed Darwin 8.01 on my computer on an HFS+ partition. I have downloaded X from the x.org website (curl http://ftp.x.org/pub/X11R6.9.0/src-s...9.0-src.tar.gz > X11.tar.gz) and extracted it (gzip -dc X11.tar.gz > X11.tar ; tar -xf X11.tar ; cd xc). That works fine, I then try to build it (make World install). It builds with many errors and then installs to /usr/X11R6/. I add /usr/X11R6/bin/ to my path and try to start it (xinit or startx), however, it gives me an error telling me that X does not exist (the executable) it says it could be a simlink to XDarwin or XQuartz. So I checked the bin folder (ls /usr/X11R6/bin) and I do not see either of those files in there. It seems they do not build for some reason, but everything else does. I tried using gcc-3.3 gcc-3.5 and gcc-4.0 which all came installed with darwin, I also tried gcc-4.1 which I compiled myself. All resulted the same way. I looked online for instructions and they were almost identical to what I did, except they told me to get the source from via cvs. What should I do?
QUOTE Thanks