View Single Post
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,699
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.9, iPhone5s, iPad Air, AppleTV2

mrplow is offline
My current install of Leopard has been running fine since it was installed, 3 days after Leopard was released. Never had any major issues.

In the last couple of weeks however Spotlight indexes, seemingly randomly. It brings the machine to a grinding halt for a couple of minutes, then you get 2-3 minutes use before going at it again. This problem gets even worse when using Safari.

If I reboot the machine it always seems to do a 'full' index which takes 2-3 hours.

I've tried permissions repairs, Onyx and Main menu spotlight index cleaning, cache cleaning.... the list goes on.

Finally seemed to sort itself out after a mammoth 5hour re-index this weekend.

Tried spotlight this morning and it's only bringing back dictionary results.

I'd previous added my downloads folder to the Privacy tab (thinking that downloading new files etc was causing the re-indexing). Came to remove the downloads folder from the privacy list and I get error "The item couldn't be added or removed because of an unknown error" - arrggghhhh!!!! Can't add or remove anything from this list.

For info:
I have a 250gb disk that has 70gb free.
The last 'significantly sized' software to be added was iLife '09 - anyone know of any issues with iLife 09 and spotlight?

I've Googled and Googled but I just seem to be going around in circles. Disabling, re-enabling and re-indexing but the results seem short lived.

I'm hoping that someone here will have a different take on the problem, ideally someone that has experienced and resolved similar issues.

Fingers crossed. Don't really want to resort to the old windows stalwart of flattening the machine and re-installing from scratch.

TIA
mrplow

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks