View Single Post
mshale

 
mshale's Avatar
 
Member Since: Aug 02, 2007
Location: Alabama
Posts: 280
mshale is on a distinguished road
Mac Specs: MacbookPro 2.5GHz, 4GB RAM, 250GB @5200 rpm Hard Drive, OS X 10.5

mshale is offline
I found a solution!!

Yep, that solved my problem too. So a precise walkthrough for the solution:

1) Go to settings, Wi-Fi, choose the network and hit the blue button. Touch "Forget this network" and confirm.
2) Now go back into Wi-Fi settings, choose the network again and join it.
3) Now hit the blue button and go down to the DNS line. Select the line and drag your finger to the left until you find the first DNS entry (entries are separated by commas). In my case, for instance, the first entry was 192.168.1.99--a local address on my network.
4) Use the backspace button to delete the first DNS entry.
5) Touch "Wi-Fi Networks" to go back.
6) Open safari and try visiting a site by URL: www.apple.com for example.

This worked for both my iPhone 3G and iPod Touch. There was no need to reboot the router, reset my network settings, or anything like that--just follow the steps above.

Incidentally, the DNS address I had to delete--192.168.1.99--was actually a static address on my network that I had allocated to my printer. So it was a very bad guess on the iPhone/iPod Touch's part as to where the local DNS server would be. But someone else's comment rings true, that the bug seems to be in the iPhone OS and has to do with falling back to the next DNS address if the first one fails--or falling back in a timely manner.

Yeah, you're welcome, Apple engineers. We're happy to do your work for you and pay for it too!

One does what one can... but together we can do more.
QUOTE Thanks