View Single Post
mysterd429

 
Member Since: Apr 01, 2008
Posts: 11
mysterd429 is on a distinguished road

mysterd429 is offline
Hi all,

Maybe it's a little odd, but I'm trying to install MediaWiki as a learning experience on my G4 running 10.4.11. I want to build things from source. There's no real good reason for doing this. I just want to.

I downloaded the source for Apache httpd 2.2.9, mysql-5.0.67, and php-5.2.6, as well as MediaWiki 1.13.0. I want to configure them to all install in their own directory, so that I don't accidentally overwrite things. I haven't done this before, and I'm not quite sure where to start. I tried compiling everything using --prefix=/wiki/{package name} --exec-prefix=/wiki/{package name}, and this all worked find, but when I tried to run httpd, I got

Code:
[Don's G4:/wiki/apache2] dlavelle% bin/httpd 
dyld: Library not loaded: /wiki/lib/libaprutil-1.0.dylib
  Referenced from: /wiki/apache2/bin/httpd
  Reason: image not found
Trace/BPT trap
Obviously, I did or didn't do something.

So, I deleted my /wiki directory and decided to start again. Any advice?

Thanks!
QUOTE Thanks