View Single Post
smilemoveon

 
Member Since: Feb 10, 2008
Posts: 7
smilemoveon is on a distinguished road

smilemoveon is offline
Quote:
Originally Posted by Dysfunction View Post
You may need to tunnel through ssh.

http://www.macupdate.com/info.php/id/10128

http://www.u.arizona.edu/consult/macx-tunnel.html

You will also likely need to start VNC on the linux box

I still have not got the vpn server address, as the IT support in our uni did not know and cc my email query to other colleauges to ask anybody know my query, the department support said no way. These IT support drove me mad.

vnc rpm could not be relocated when I tried to install it in my home directory to skip the sysadmins at the Uni.

I also tried cisco vpn, it is always not connected when I tried every server address I know(including the ssh server), I could not see I can go any further without the correct vpn address.


Quote:
Originally Posted by GroovyLinuxGuy
Instead of tunneling through vnc, you could try NoMachine's NX client and server setup
http://www.nomachine.com/
As NoMachine works over ssh, I think it is a possible way to get it work as I can ssh successfuly over terminal and to skip the vpn server address, please correct me if I am wrong. now I am stuck in installing the server on my linux machine. Please anybody got an idea or share your experience.

my linux is CentOS, I am new to linux as to mac, not sure which NXserver I should download, I do not have root permission, so I tried to install it in my home directory.

I downloaded NX Enterprise Desktop server for Linux Evaluation_x86_64,
tar xvzf the 3 packages.targz
/nxnode --install --prefix=$HOME, got the error message"can not create configuration file", still the same error message even without "--prefix=$HOME"

/nxserver --install, got the error message" Error: Output:/bin/bash; useradd:command not found.
Error: can not add user:nx to the system."
QUOTE Thanks