View Single Post
MacHeadCase
Guest
 
Posts: n/a

Welcome to Mac-Forums, mikeml.

They aren't compatible with Leopard, that's for sure. The cut for Leopard is a G4 1GHz and faster. To make sure of what you can do with Leopard, go to Apple.com.
QUOTE Thanks