View Single Post
PatrickB

 
Member Since: Mar 16, 2008
Location: Netherlands, The
Posts: 34
PatrickB is on a distinguished road
Mac Specs: PowerMac G5, 2x 1.8GHz, 2GB RAM, 160+80GB HDD, OS X 10.5.6, nVidia GeForce 5200FX

PatrickB is offline
Hello,

I am running Mac OS 9 on my beige Mac G3. Because I need/want USB ports on this machine, I bought a Belkin F5U220 PCI card. According to the packaging it supports Mac OS 8.6 and higher.

Unfortunatly, it crashes my Mac during bootup with error 19, and says I should boot without extensions. It even says so when I boot without extensions. Is there something that I am doing wrong, or is this card just incompatible?

The card isn't broken, because it does work on my Linux machine, but I already had a UHCI/EHCI card installed in that.

The card I bought is this: Belkin F5U220. When looking under specs there it also doen't mention Mac OS 9, but just Mac OS X. Still, the packaging said it supported OS 9.

What am I doing wrong? Should I just return this card and get another one?
QUOTE Thanks