View Single Post
fredk

 
Member Since: Apr 11, 2007
Posts: 3
fredk is on a distinguished road

fredk is offline
Hello.

Before you burst out with "Use WPA," read this: I just moved into a houseshare and I do not control* the access point, and the landlord, who owns and controll the access point. has to use WEP because of a couple of old computers. The Access point do not allow to run both WPA and WEP, only once at a time. This means that I am stuck with WEP.

My computer is a white MacBook Core 2 Duo 2 GHz, 1 GB ram, bought in December 2006, in Norway (I am now living in London) The router is a D-Link G604T.
And for all the info is worth, about a month ago I dropped the MacBook. It left a nasty dent and I had to change the hard drive. No other problems.

Now to the problem itself, I cant connect to the WEP protected network which is available in my house. It simply wont work. (I can connect just fine with no security or WPA.) The password is "09345678AB".
Ive tried all obvious solutions like putting $ or "" infront of the password and changing the password as seen in the article from Apple presented further down the post, Ive tried the various options from the drop down-menu when you type in the WEP-password. And I have restarted both the airport card and the router a numerous times.

If I get this article right, http://docs.info.apple.com/article.html?artnum=108058 , my problem goes a little deeper.
If I understand it right, the problem is that it is no real standard for wep passwords, because WEP came before the Wifi Alliance. Therefore, different manufacturers, may "handle" (format? encrypt? decrypt?) the password differently, meaning that when I type in the password on the MacBook, it will simply turn up wrong for the access point. Am I right?

I made a Genius Bar appointment at the Apple Store at Regent Street (London), and presented the genius with the above Info. However, he just checked my network settings, blamed the access point and said that there was nothing more he could do for me.

So, is it any solution to this problem? Anything at all, or am I just stuck?
Could I, as a secondary solution, buy a usb wifi adapter and use it instead of Airport?

Thanks in advance for all the help and please bear with me for not using all the right terminology.
QUOTE Thanks