View Single Post
henryo11

 
Member Since: Jan 22, 2007
Posts: 51
henryo11 is on a distinguished road

henryo11 is offline
So I purchased a 500GB Seagate SATA hard drive that I put in an AMS Venus USB 2.0 external enclosure recently and while it has been working fine for the most part, occasionally it decides not to mount. This happened once a few months ago when I first got the drive. I remember I started copying some files from my other external drive but stopped it so I could plug the drive into a surge protector and when I turned the 500GB drive back on it wouldn't mount.

After some time (maybe a day or so) OS X recognized the drive and it had been working fine, until yesterday that is.

After copying some songs from my 500GB drive to my iPod and restarting my computer, the external would not mount (Tried removing the iPod, switching USB ports, turning off anything else that was plugged into the same surge protector as my drive). Tried booting into windows via bootcamp to see if the drive would show up (I have a 65.75 FAT 32 partition on the drive) but alas, nothing.

I just turned my computer on a minute ago and miraculously everything works fine again, but I have no idea why this drive decides not to mount sometimes.

The drive model is ST350064
and I am using this enclosure
http://www.newegg.com/Product/Produc...82E16817145660

Any help would be greatly appeciated
QUOTE Thanks