View Single Post
Checco

 
Member Since: Nov 09, 2011
Posts: 225
Checco has a spectacular aura about
Mac Specs: 21.5" iMac Mid-2011 ~ 15" MBP Mid-2012 ~ iPad 4 16GB ~ iPhone 5 16GB

Checco is offline
I'm running 5.8.0.1027. I think I settled on this version because it was the oldest one I could get my hands on at the time. Regarding the crashes, the latest version was installed on a clean OS. Was just starting out on OSX so only had Fusion and Office 2011 installed. It would crash when opening the App and viewing the contacts list.

5.8.0.1027 works fine and I often call Skype-to-Skype and use Skype Out. Hence no need to "risk" upgrade at this point (although an old version may be seen as a risk in itself). Skype is just a small part of my toolset, that it just works is more important than having the latest version (to me). Plus let's not forget that MS owns it: given enough time the install footprint should reach 4 TB and require the new Mac Pro to run it.
QUOTE Thanks