View Single Post
pigoo3

 
pigoo3's Avatar
 
Member Since: May 20, 2008
Location: U.S.
Posts: 26,564
pigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond repute
Mac Specs: 13" MB 2.4ghz, 2gig ram, OS 10.7.5

pigoo3 is offline
Quote:
Originally Posted by AndrewGomes View Post
App support, being able to run the latest versions of Adobe Suite, iTunes, etc
As far as Adobe...you would need to check Adobe's web page to see what the system requirements are for the version of Adobe products you are running.

Generally speaking...developers of non-Apple apps determine what OS version they want their products to be compatible with. If Apple releases a new OS version (with new abilities & features)...software developers want to take advantage of that.

So for example...Adobe CS6 I'm pretty sure requires a newer version of the Mac OS than Adobe CS5. So you need to check what version you are running...so you know what OS version is needed.

As far as Apple apps (like iTunes)...it does look like the latest version of iTunes (11.0.4) is still compatible with Snow Leoaprd (10.6.8):

Apple - iTunes - Download iTunes Now

- Nick

- Computer slow, too many "beachballs", read this: Beachballs
- Computer seems slower than it used to? Read this for some speedup tips: Speedup
- Almost full hard drive? Some solutions. Out of Space
- Apple Battery Info. Battery
QUOTE Thanks