View Single Post
Rachwomaninoff

 
Member Since: Oct 09, 2012
Posts: 7
Rachwomaninoff is on a distinguished road

Rachwomaninoff is offline
I'm trying to troubleshoot my brother's black Macbook (10,4). Upon powering on, the screen goes white. I know about all the commands; I've tried them all. Two times I've been able to click on the OS X Installer disk and get to the Disk Utility from the Utilities tab. What was strange is I never saw the Macintosh HD but instead 'HitachiHTS54...' and 'disk4s2' (the former one had all the 128something GB on it). I tried repairing the disk and doing a few other things, but the disk couldn't be repaired. I closed out of this and powered off the computer yet again.

However... since then, I've not been able to get back to the Disk Utility by clicking on the Installer disk (getting there by holding down C while booting). I know my keys are working because I see the arrow when I hold down Option/Alt and see the folder with question mark when holding down C. This is really frustrating because, at this point, I don't care if everything's been lost on the hard drive. I just want to get back to where I was at to clean install, but can't figure out a work around.

I've been searching everywhere for answers and finally got a solution:

1.- Remove the hard drive.
2.- Boot off the startup CD and set boot option to CD. Then just shutdown. Donít restart yet.
3.- Plug in the hard drive and power on the Macbook WITH the CD inserted. It should boot off the CD as instructed.
4.- Using the hard drive utils, FORMAT the hard drive.
5.- Restart now without the CD in. It should boot.

Notes: a) if at step 2, after setting boot option to CD, it only gives you the restart option, then plug in the hard drive while computer still on and restart (without removing the CD, of course, so that it can boot again).
b) yes, when you change boot options from bootable CD, those changes apply next time you boot.
c) you HAVE TO format your hard drive before trying to boot off it; otherwise you get the white screen again because the firmware is trying to find the boot sector in your hard drive.


Since I saw only the restart option as mentioned in 'Notes', I followed the steps given. I was able to finally get back to where I was, however, the 'HitachiHTS54...' and 'disk4s2' were both missing.

Is there a chance maybe I didn't insert the hard drive back in all the way? I did everything precisely. Does anyone know why I was seeing 'HitachiHTS54...' and 'disk4s2' in the first place, and why I can not see it now (12 hours later)? Is my hard drive ruined? If so, why was I able to see 'HitachiHTS54...' and 'disk4s2' with data on it? Is there a way I can get the hard drive to show again in disk utility upon booting?

Please, if you have an answer or suggestion or another thread to answer my specific concern, do let me know!
QUOTE Thanks