View Single Post
magnitude

 
Member Since: Feb 27, 2011
Posts: 88
magnitude is an unknown at this point
Mac Specs: 15" MacBook Pro Retina, 2.7 GHz quad core i7, 16GB 1600MHz DDR3L SDRAM, 512GB flash...

magnitude is offline
Quote:
Originally Posted by vansmith View Post
This has nothing to do with Apple and everything to do with Oracle. For whatever reason, Oracle decided to make Java 64bit only and since Google does not ship a 64bit version of Chrome, it can't use it (you can't load 64bit plugins in 32bit browsers). Blame Oracle, not Apple for this one.

I don't know how you uninstalled it but follow the instructions here. Assuming you've done that (and assuming you are using Lion as your post suggests), you should be ready to install Java 6. You could also just wait until a Java applet needs to be loaded since OS X will prompt you to install a runtime when one is invoked.
No I did it the way they explained on the Java home page. Here: How do I uninstall Java 7 for my Mac?

So I can't find what they point to in that article you linked to. So I tried this:

On the same page you can read about how to reinstall the Mac:

Restore Apple's Java after uninstalling Oracle Java 7
If you find an issue using Java 7 and would like to continue using Apple's Java on your Mac, you will need to first uninstall Java 7, then restore Apple's Java
Note: To restore Apple's Java, you must have Administrator privileges and execute the command either as root or by using sudo.
Click on the Finder icon located in your dock
Click on Applications tab on sidebar
Click on the Utilities folder
Double-click on the Terminal icon
In the Terminal window Copy and Paste the command below:
sudo ln -s /System/Library/Java/Support/CoreDeploy.bundle/Contents/JavaAppletPlugin.plugin /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin

But when I do that basically nothing happens. I was asked to give my psw. Did that. I did it another time, then I got the message:


ln: /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/JavaAppletPlugin.plugin: File exists

Tried software update and tried to install the java install file I downloaes from Apple. Still nothing.

I sure would appreciate if someone could help me get java back!
QUOTE Thanks