View Single Post
mcgilberyair

 
Member Since: Mar 10, 2012
Posts: 1
mcgilberyair is on a distinguished road

mcgilberyair is offline
I've got the same problem but from a reverse perspective. I was converting some vids using friends macbook pro and hadn't noticed that the power connection had come unplugged. It shutdown and after connecting power, waiting approx 15 minute, powered up, then when looking for the PNY 64 gig usb memory stick, poof it was gone. I looked for it using finder, gave disk utility a peek, no joy. I powered the mac book down, removed usb and tried it in My mack book air, same results, then tried it in XP based work laptop and had same results as original poster. It shows as "Removable Disk (E" and then when try to click on it in xp, asks "Please insert a disk into drive E:." Frustrating, I am certain of an nearly identical incident with a seemingly fried memstick with a document control guy here at work that mention it occurred after a power down from battery depleted. Is there a more aggressive way to look for the usb device on a mac OSX Lion (10.7.4) ?
QUOTE Thanks