View Single Post
kj0

 
Member Since: Jun 01, 2009
Location: Brisbane, Australia
Posts: 12
kj0 is on a distinguished road
Mac Specs: MacBook | iMac | iPhone | iPod | eMac

kj0 is offline
HI All.

I've just written a small (Very Small) applescript to add a printer for those users we have here in our organisation that have a MacBook. We are primarily PCs so of course our printers are set up that way.

The issue I am having is when I point the line for the printer driver to a network location the script can not find that file, however, when I run the line for a local location it works and installs.

The network location is just a NAS with Everyone set to Full Permission.

Code:
do shell script "/usr/sbin/lpadmin -p QF_STAFFROOM -E -v lpd://<Server>.<Blah>.<blah>/P2132QF26D513/P2132QF26D513 -P smb://xx.xx.xxx.12/Printers/Dell_5130cdn.gz -D \"QF StaffRoom\""


IF I run this commend it works like a treat.

Code:
do shell script "/usr/sbin/lpadmin -p STAFFROOM -E -v lpd://<Server>.<Blah>.<blah>/P2132QF26D513/P2132QF26D513 -P /resources/Dell_5130cdn.gz -D \"StaffRoom\""


Thanks
QUOTE Thanks