View Single Post
Duane01

 
Member Since: Jan 25, 2012
Posts: 11
Duane01 is on a distinguished road

Duane01 is offline
So I was given an old Macbook today by a friend who thought it was broken and if I could fix it then good for me and I keep it.

At first I plugged the charger in and no lights were present on the charger on the battery and it wouldn't turn on. After 10-15minutes the light was present on both the charger and the battery but the Mac would still not turn on.

After a further 10minutes the Mac would turn on, however it toke a very long time to load and crashed when it booted into the operating system, after booting it a second time all was working fine, apart from the fact if the Mac wasn't kept active it would turn off instead of sleep.

So I wanted to clean up the Mac and put a fresh operating system on it, originally I tried using a install cd from a few year old Macbook Pro, which I had to use an external dvd drive and it would not install saying it can't be installed on the computer, after which I got a regular Macbook install cd and tried that with no luck still.

I tried booting up the Mac with the installation cd and it said it can't install, at which point I went into the Disk utility and earsed the drive and began to zero it as well, unfortunately during the process of zeroing the computer appearingly just turned itself off (I'm suspecting when it goes into sleep or on the screensaver something is going wrong).

So now after turning the computer off and trying to start it again the computer will never get past the Apple icon when it's trying to load. When I turn it on it goes to a flashing folder icon and when I connect the external dvd drive it switches to the Apple icon. Unfortunately the computer just keeps turning off.
The computer however doesn't behave like it's been turned off because when you press the power button again nothing happens (if you close the Macbook you see the light in the right corner), you have to hold it breifly and then press it again for it to start up again. Sometimes when you turn it on nothing happens (but again I have to hold the power to completely turn it off), sometimes it makes it to the flashing folder icon and sometimes to the Apple icon.

I've read about people having similar issues with the sleep but not found a solution.

I'm at no loss if I can't fix it as it was free, however I don't have a computer of my own and it would be nice if someone can help me.
QUOTE Thanks