View Single Post
schmittstix

 
Member Since: Aug 21, 2011
Posts: 10
schmittstix is on a distinguished road

schmittstix is offline
I've scoured the internet and haven't found a solution for this specific permissions problem...
I have 3 users set up on my MacBook Pro. I use one for personal use and the other two for work. They are all set-up as administrators. I found that I often needed to access the desktops of the other users and move files back and forth. Each time I made a change, I had to change permissions for the individual file. So a few months ago I thought it'd be smart to go to 'get info' on my HD icon and change the permissions to "Admin : Read & Write" and selected the "apply to enclosed items" option. It took a long time to churn through everything , but it changed the permissions for everything on my HD. I then read somewhere that doing this type of permissions change to your computer's entire HD was really risky. Miraculously , this didn't cause any apparent problems for me. But every time I create a new file, I'm stuck with the old problem of having to change the permissions.

Is there a way to change the default setting for new files/folders created so that multiple users can read & write ?

also..
Is there a correct way to do what I originally attempted? Can this be done in Terminal or with some kind of app like Tinker Tool?

another thing I tried..
I also toyed with the permission settings in system preferences> sharing >file sharing but it seemed to do nothing (I created a text edit file to test it.. then logged into a different user and opened that test file I created. But when I tried to save it I got the same ol' message : "The document could not be saved. You don't have permission" )
QUOTE Thanks