View Single Post
Mets21

 
Member Since: Sep 01, 2011
Posts: 47
Mets21 is on a distinguished road

Mets21 is offline
well i got a new hard drive. and I have nothing on it yet at all. I saw that on apple.com they had the snow leopard software for sale for 29.99 $ i believe that's the 10.6 I was wondering do I have to have a previous version of any software like snow leopard or leopard for it to work on my mac. I dont have any installation disks of previous versions. This is brand new hard drive to. I was hoping to get the software and just put in the cd and go from there and get it working again. let me know i really need help, thanks guys.
QUOTE Thanks