View Single Post
MS12

 
Member Since: Jun 22, 2011
Posts: 1
MS12 is on a distinguished road

MS12 is offline
Hi, this is my first post, so please excuse me if I am in the wrong forum area, or if I do anything else wrong.

I have a 500GB iOmega Prestige portable hard drive that seems to be frustrating me to no end. It was purchased about 3 years ago and worked up until recently.

I suppose I will just start from the beginning. I have a 13" MBP. I tried to go into Disk Utilities (DU) and go through as many of the trouble shooting steps as i could fathom, and find on the internet. (FirstAid; repair disk, Erase, Partition, reboot Finder and then try all over again). nothing I did in DU worked, until finally one time something changed and now all I can see on the lefthand bar is the factory name of the external HD (500.11 GB ST950032...) and underneath that there is, in faint grey text, "disk1s2" (that appears to not be mounted). I have also tried to mount that disk without success. the drive does not apear on the desk top, and any attempt to repair, erase, or partition it fails with various messages.

Currently when i plug the HD in VIA USB i get a alert that says "The disk you inserted was not readable by this computer" then it provides 3 buttons, Initialize, ignore, and eject. If i hit initialize DU opens with the HD on the left but non responsive to any actions.


I hope there is still a chance I can get this sucker back in working order. I can and will provide screen shots and more info as needed.

I hope I provided enough information to comprehend the problem.

THX!
QUOTE Thanks